Showing results for 
Search instead for 
Did you mean: 

Unable to install LiveSafe

Hi Everyone,

I noticed recently that the McAfee shield wasn't appearing at the top of my Mac where it normally does.

So I uninstalled it and attempted to reinstall it...

Upon reinstall it kept telling me that I needed to uninstall the original install first... but I had already uninstalled it.

When the installer asks if it can do the uninstall - I choose yes - but got an error.

Thanks to Mr.Google I found a McAfee article that listed all the locations that I might find a McAfee artifiact, and so I deleted them all and attempted to reinstall.

The install was taking forever, and by forever - mean it was still saying "We're checking for software that might be incompatible...." after two days.

So I abandoned the install - re-deleted all the artifacts and am attempting to reinstall again...

And well after two hours - it is still telling me the same message at step 1 : "we're checking for ......"

I am using the installer, that I get from the download page within my account;

McAfee mac Installer 3.3

I am using MAC OSX, with all the latest updates applied.

If anyone has any ideas, I would be most grateful....

i also wouldn't mind hearing about why it stopped in the first place - if there is anything that you might think of...


0 Kudos
7 Replies
Level 21

Re: Unable to install LiveSafe

I moved this to Mac Products so that perhaps someone with knowledge will help.

Meanwhile I would contact Technical Support directly, it's free of charge and you can ask for escalation if at first they can't help.

Sorry, none of us Moderators have Mac knowledge.

Contact Support



Volunteer Moderator

0 Kudos
Level 7

Re: Unable to install LiveSafe

I had the same problem yesterday. I tried to install twice on my MacBook which is running ElCapitan 10.11.6 and using Safari 9.1.2. Then I used the chat service through tech support. The technician took over my computer and tried 3 times.  Problem persisted. At 11:30 p.m. the chat and "take-over" app terminated and I kept working. The technician had originally cleaned my machine of all remnants of an older version. Still wouldn't install. He asked me if I had any wireless equipment attached, and I disconnected my wireless mouse.  Problem persisted. He checked a few other things in preferences but made no changes.

When I started back on my own, I read your posts. Then I had a pop up about updating Java. I seem to get that daily and install Java over and over again, so I did that install again, tried to install McAfee again with the same problem AGAIN.  Problem persisted. I had noticed a direction on the Java page, which I checked following the directions, changed a setting in preferences. Success.  So where did I go, what did I do?

Under the Apple, choose System Preferences, Choose Security, (The directions told me to be sure everything was checked and it was.)

Then I clicked "Plug-In Settings" in the last line. (I read  to be sure that McAfee and Adobe were always allowed with the java Plug in.)

The radial buttons were set at "Allow."   I clicked on the radial buttons for each of those applications and changed them to "Always Allow".

Within 30 seconds, the installation which was STILL operating in the background finally stopped checking my software for incompatibilities and moved to the next step of downloading files. I was so surprised to finally be asked for the McAfee Serial number. I had copied it down 6 times and never been asked to paste it for all those installation trials. A couple of minutes later installation was complete and I was running my first scan, which found 5 threats, deleted 2 files, quarantined 2 files.

AND I did that fix with my wireless mouse attached.

Hope this is of some help to others.  NOW, if I could speed up my MAC which has seemed to be walking in cement since my update to ElCapitan, I'd be a VERY happy Mac-er.  Right now, my HP running Windows 10 has it beat for speed. 5 minutes+ to open any application is NOT Mac-Like.

Bravelute, a resolute Macintosh owner for 17 years. Till now. Sorry for this vent on the McAfee site. I was hoping the McAfee scan might find something that would be the culprit. But it didn't solve the slows.  Oh well.  I'll keep working on this mystery.

Perhaps someone would add this Preferences solution to the technicians list of things to try for this problem.

0 Kudos
Level 21

Re: Unable to install LiveSafe

Thanks bravelute for that, I hope too that it helps someone.

0 Kudos
Level 7

Re: Unable to install LiveSafe

Why dont your try to go into your terminal and type

sudo su

At this point enter password. Note that nothing would apper as your are typing your password. Just type it and hit enter. At this point type the following:

sudo find / -name '*mcafee*'

This way you will look for any kind of mcafee leftovers. Delete them

sudo delete / -name '*mcafee*'

Reboot and i believe you should be able to install mcafee if this was the only reason. By the way i would turn off the time machine while installing if i were you.

Take care

0 Kudos
Level 7

Re: Unable to install LiveSafe

How does one go into the terminal on a MAC?  I used to do that on Windows system computers, but never on a MAC.  Very interesting if this is possible.  Can you give me a link so I can learn HOW, and When I would want to do this?

Can you tell me what the command "sudo su" means?

0 Kudos
Level 20

Re: Unable to install LiveSafe

On OS X, open your Applications folder, then open the Utilities folder. Open the Terminal application.

At least this what Google says

0 Kudos
Level 7

Re: Unable to install LiveSafe

Sorry i have been on vacation and didnt have any access to the web.

Sure I will explain! To open the Terminal just click on the search symbol on your Mac and type in “terminal”. You cant confuse it.

The sudo command is used to execute commands as a different user. The su at the end indicates for Super User. Kinda like the built-in windows administrator account. Or more like the System account in Windows. Anyway…

So the sudo su will elevate the terminal to super user right. You would be prompted to type in password. The field would remain blank and you wont notice that you are typing anything. But you are. Simply type the password of the current logged user and hit enter.

As a matter of fact try these:

sudo find / -name ‘*mcafee*’     …….. this will scan the entire system for files or left overs. Give it some time. For most of the part it would look as it does nothing but it does. Even at the beginning there would be couple of messages that a certain value is not a directory or something. Then within 10 min give or take the scan will finish. You will notice that you can still type in while it scans because as I said it looks like either doing nothing or it completed the scan. The current logged in user name will appear. Just then enter the next command.

sudo find / -name ‘*mcafee*’ –delete   ………………..   this will remove all found mcafee data from you system. What I said above is still valid here.

Re-start the Mac so that the OS will start without the files and processes that were running before. After restart, turn off you time machine: Click on the Apple -> System Preferences-> Time Machine. Please make sure it is off. I read in another article the sometimes the installation gets stuck for days when the time machine is active. You can surely turn it back on when mcafee is installed.

Open Safari and go to your account to log in and start a new installation. I wouldn’t run the same installer i userd the last time if I were you.

Take care!

0 Kudos