cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

McAfee Lifesafe Firewall blocking IPV6 access in WSL (Windows Subsystem for Linux) on Win10

This problems happens on various builds on Windows 10 (1709, 1803, and earlier ones), and most of recent updates of McAfee LifeSafe (don't remember when first noticed this issue). Current version 16.0R3, Firewall 18.3.130.

With Firewall turned on:

root@xxxxx:/home/zzzzz# ping6 www.google.com
PING www.google.com(sfo07s26-in-x04.1e100.net) 56 data bytes
^C
--- www.google.com ping statistics ---

9 packets transmitted, 0 received, 100% packet loss, time 8016ms

In the log I see that DNS replies are blocked. It works fine from CMD though.

When Firewall is disabled everything works as it should:

root@xxxxx:/home/zzzzz# ping6 www.google.com
PING www.google.com(sfo07s26-in-x04.1e100.net) 56 data bytes
64 bytes from sfo07s26-in-x04.1e100.net: icmp_seq=1 ttl=54 time=9.76 ms
64 bytes from sfo07s26-in-x04.1e100.net: icmp_seq=2 ttl=54 time=12.1 ms
^C
--- www.google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 9.767/10.959/12.151/1.192 ms

Labels (2)
4 Replies

Re: McAfee Lifesafe Firewall blocking IPV6 access in WSL (Windows Subsystem for Linux) on Win10

@vsukhoml

Open McAfee, Click PC Security tab on the top and select Firewall (on the left part of the screen). Scroll down and select My Network Connections. Click Add and type the IP address of the concerned application under IP Address VersionIPV6.  Select your Network type and Save it. Check now

Regards
Siva 

Re: McAfee Lifesafe Firewall blocking IPV6 access in WSL (Windows Subsystem for Linux) on Win10

unfortunately, there are 3 problems with this solution:

1) I tried it, it doesn't work

2) IPV6 address of router is changing, so will have to update it regularly

3) Somehow Firewall blocks UDP from port 53 on router to only WSL applications, so IPV6 is not resolved properly.ipv6-wsl.jpg

Re: McAfee Lifesafe Firewall blocking IPV6 access in WSL (Windows Subsystem for Linux) on Win10

@vsukhoml@vsukho

Please try the below steps
1. Enable Port 80 and 443 under McAfee Firewall > Ports and System Services
2. Add the Port No.3000 under McAfee Firewall > Ports and System Services > Add > Local TCP Port > Save it.
3. Add the Port No.53 under McAfee Firewall > Ports and System Services > Add > Local UDP Port > Save it.
4. Enable Allow ICMP Ping requests under McAfee Firewall > Smart Advice and Advanced Settings 

Regards
Siva

 

 

 

Re: McAfee Lifesafe Firewall blocking IPV6 access in WSL (Windows Subsystem for Linux) on Win10

Unfortunately, it doesn't affect behavior for WSL apps, ping6 still can't send ICMP to servers, and on Ubuntu 18.04 there are problems connecting using TCP to servers resolved to IPV6 addresses. 

 

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community