cancel
Showing results for 
Search instead for 
Did you mean: 

LiveSafe Blocking Remote Desktop Connections

Jump to solution

There was an update on 06/28/2018. Before that I could use RDC and map drives for file sharing. on my local server. Now neither work. If I turn off McAfee firewall they all work. I do not get any notifications

1 Solution

Accepted Solutions

Re: LiveSafe Blocking Remote Desktop Connections

Jump to solution

Sorry I had not updated my post.  The problem was not McAfee.  I found my router was forwarding port 3389 to the wrong internal IP address for my PC.  Once corrected, it now works.

5 Replies
Highlighted
Moderator ymdfarhan
Moderator
Report Inappropriate Content
Message 2 of 6

Re: LiveSafe Blocking Remote Desktop Connections

Jump to solution

Hi @stodola

Since turning off Firewall is allowing you to access your local server, please allow the IP address of the server under Firewall settings. Open McAfee Firewall and allow the IP address under My Network Connections.

Was my reply helpful? If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Regards
Farhan

Re: LiveSafe Blocking Remote Desktop Connections

Jump to solution

McAfee Livesage is blocking Remote Desktop Connections but turning off the firewall does not help.  Under the Ports and System Services Remote Desktop Assistance/Terminal Server port 3389 is enabled.

Under Internet Connections for Programs the Windows Remote Assistance Com Server if Off for Work and Home Networks.  How do I turn it On?

The next entry...Remote Desktop Assistance is Off for All Devices.  How do I turn it On?

Thanks

Moderator ymdfarhan
Moderator
Report Inappropriate Content
Message 4 of 6

Re: LiveSafe Blocking Remote Desktop Connections

Jump to solution

Hello @freddiecarroll

Under Internet Connection for Programs, below is the sequence that I think you see as per what you have mentioned.

Windows Remote Assistance Com Server - Work and Home Networks - Off
Remote Desktop Assistance - All devices - Off

What that means is that:
1. Windows Remote Assistance Com Server is allowed to be accessed by Work and Home Networks and the NetGuard is switched off
2. Remote Desktop Assistance is allowed to be accessed by all devices and the NetGuard if off.

The above settings should not be causing the problem.

Please confirm if you face this issue after uninstalling McAfee (if you have attempted to do that)

Regards
Farhan

 

Re: LiveSafe Blocking Remote Desktop Connections

Jump to solution

Sorry I had not updated my post.  The problem was not McAfee.  I found my router was forwarding port 3389 to the wrong internal IP address for my PC.  Once corrected, it now works.

Moderator ymdfarhan
Moderator
Report Inappropriate Content
Message 6 of 6

Re: LiveSafe Blocking Remote Desktop Connections

Jump to solution

Glad it is working now. I will mark your response as the solution to this thread.

Thanks
Farhan