cancel
Showing results for 
Search instead for 
Did you mean: 

MEG 7.6 and Outbound Mail from Domino

We're running into a problem on out outbound MEGs in how they are handling mail from Domino. 

In the 6.7.2 world, mail would immediately be taken by the mail gateway.  If it couldn't deliver it, it would stay on the gateway and go into retry state. 

Under 7.6, if the MEG can't deliver the mail, it doesn't accept it and it stays on the Domino server.  This is causing some problems as we've seen a backup of as many as 4600 messages.  SO, our alert system shows email delays and it's not pretty. 

I am assuming there must be someone already using 7.5-7.6 to route outbound mail from Domino.  I know there is the option of setting the gateway up for store and forward.  Are there other options?

3 Replies
ijahnke
Level 11
Report Inappropriate Content
Message 2 of 4

Re: MEG 7.6 and Outbound Mail from Domino

Ron,

You can use store and forward on the MEG devices.

Email -> Protocol Configuration -> Protocol Settings -> Message Proccessing -> Store and forward email if: The message Size exceeds 1KB. (Can be reduced to 0KB by support)

Basically this will handle mail the same way that IronMails did.

Re: MEG 7.6 and Outbound Mail from Domino

Thanks Ivan,

We found another setting that we may try before that. Under Email Configuration - Sending Email - Queued mail delivery

There is a setting for Emails per connection. The McAfee consultant who was here for our upgrade set it to 5. We raised it to 10 one one of the appliances. That seems to be showing a significant decrease in mail queue buildup on the Domino servers. Instead of having 4500 messages backed up, we are getting a peak of about 400. Do you think this is another viable option?

Re: MEG 7.6 and Outbound Mail from Domino

Hi Ron,

Just got off the phone with a customer using domino as well and he was seeing the same problem.  He tried to update this post, but he can't figure out how to log into his account on the forums(giggle).  So I am updating it for him.

Domino by default will attempt to send as many messages in one connection as it can.  in his case, I picked a random outbound message from the message search page on the MEG.  It was message number 1,313 of the connection.  At that point the connection had been open for approximately four hours.  That was his delay and I am guessing yours is the same.

He also found this link that explained how to change the behavior of the Domino server:

http://publib.boulder.ibm.com/infocenter/domhelp/v8r0/index.jsp?topic=%2Fcom.ibm.help.domino.admin.d...

On that page, pay attention to the Outbound SMTP Commands and Extensions section.  In particular, he disabled the pipelining feature and his queues cleared up.

Pipelining extension

Choose one:

  • Enabled - (default) If the remote SMTP host also supports pipelining, Domino sends multiple SMTP commands in the same network packet to improve performance.
  • Disabled - Domino sends each SMTP command in a separate packet

Let me know if that helps.

--Jake