cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
JeffGerard
Level 10
Report Inappropriate Content
Message 1 of 2

firesvc.exe and mfefirek.sys CPU load issues with HIPS 8 Patch 2

I am wondering if anyone else is having issues with P2 for HIPS8?

I have tried it on 4 different Dell laptops:

1 x E6520 with custom Win7 x64 install

2 x E6520 made from same image based on original Dell Win7 x64 install

1 x E6500 running custom Win7 x64 installation

Basically what happens is the patch installs fine, and machine will reboot and operate fine as long as you remain on a wired network.

Once you switch to a wireless network these issues start.

Based on my testing, there seems to be some collaboration between auto-disabling wireless upon wired connect, band preference, and system standby.

I still have yet to come up with any absolute way to reproduce the issue but I can almost always make it happen when switching enough times from wired to wireless to wired to wireless etc.

When the issue occurs, usually firesvc.exe begins to hog CPU. On my quad-core i7, it averages 12-13% cpu and the machine begins to run hot. On my older E6500 with dual-core, it hogs at 50%. Sometimes, the System process shows 12-13% CPU and if you open it up in Process Explorer, you'll see that the offending process is mfefirek.sys. Again, the machine will get hot. Sometimes it's just firesvc.exe and others it's just mfefirek.sys, and others it's both (at which cpu usage doubles)  In all cases, when this happens, I can still ping and run certain network services, but web browsing stops working along with https and possibly other services.

The only way to reover at this point is to reboot. If I am at home and rebooting back to a wired network, I noticed that I could only get things to work if I disabled the physical wireless swtich *and* turned off band preference (ie, 5GHz vs 2.4GHz) in the nic settings.

I plan to open a case with McAfee but don't have the time to do any troubleshooting at this point in time. I'm more just curious if any others are experiencing same or similar.

Cheers

/Jeff

1 Reply
Pmaquoi
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 2

Re: firesvc.exe and mfefirek.sys CPU load issues with HIPS 8 Patch 2

the patch 2 works fine for us WITH Firefox 10.0.6 and previous version

CPU between 0 and 1 % and 11 MB ram

As soon as you install the Firefox 10.0.7 ESR, the CPU for the firesvc process  jump to 25% and the browser can't be launched completely. And the Firefox process becomes unstoppable.

Returning to the 10.0.6 version let the firesvc process works correctly again.

We will investigate more

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community