cancel
Showing results for 
Search instead for 
Did you mean: 

Silent install - HIPS and VSE

Hi,

I got to perform silent install of HIPS (patch + HF) and VSE (patch + HF).

I figured out that we can use the /q option for VSE, but I didn't find what option I can use for HIPS...

Thanks !

5 Replies
exbrit
Level 21
Report Inappropriate Content
Message 2 of 6

Re: Silent install - HIPS and VSE

Moved from the general area to HIPs for better attention.

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 6

Re: Silent install - HIPS and VSE

HIPS is supported by running the McAfeeHIP_ClientSetup.exe installer.  This installer .EXE file is hard-coded to run a silent install.

Re: Silent install - HIPS and VSE

Yes, but at the end is the reboot... how can I suppress that? I want to reboot later, and dont bother the user immediatly after the install.

On Version 7 you could use something like

call "...\HIPS\McAfeeHIP_ClientSetup.exe" /S /v/qn

but thats a sure way to an error message. If you use thison Version 8.0,

the msi-message screen pops up, that is responsible for informing the user about the msi-commands.

If you use

call "...\HIPS\McAfeeHIP_ClientSetup.exe"

there is an rebootmessage at the end, that I dont want the user to see.

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 6

Re: Silent install - HIPS and VSE

MSI switches do not work with the HIPS 8.0 installer (McAfeeHIP_ClientSetup.exe).  The HIPS 8 installer is hard-coded and cannot be modified, except for the use of the BYPASSREBOOT=1 switch that can be used in an ePO deployment task. 

The BYPASSREBOOT=1 switch only works with the HIPS 8.0 Patch 2 full installer though.

Re: Silent install - HIPS and VSE

That's a nicetohave, but not what we need.

We are a great IT-Company with many different customers, many different domains and different administrators with different rights, a.s.o.

We cannot use the console of yours. We need to use the exe-installation through a softwaredeploymentsystem.

Please don't tell me, you forgot to build in an option to suppress the reboot.

There's a setup.ini, and in it, there's a line called "SuppressReboot=Y". But it does not work.

There is an option to install via the .exe-file, isn't it? Please don't tell me no...