cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7
Report Inappropriate Content
Message 1 of 8

HIPS Install from ePO error

HIPS is not part of my production environment yet. No other versions of HIPS has been deployed. This is part of a pilot install prior to pushing to production.

On a single machine (Windows 7 64-bit) that I am trying to install HIPS on is returning an error in the install log that doesn't make sense to me and I can't figure out how to get around it.

The error is basically saying in order to upgrade to HIPS 8 Patch 8, it first has to already have Hips 8 Patch 4 installed. I am not trying to upgrade. Following is an excerpt from the log:

MSI (s) (A8:8C) [09:54:08:872]: Doing action: LaunchConditions

Action ended 12:22:28: LogPackageInfo. Return value 1.

Action start 9:54:08: LaunchConditions.

MSI (s) (A8:8C) [09:54:08:873]: Product: McAfee Host Intrusion Prevention -- Upgrade is supported only if McAfee Host Intrusion Prevention 8.0 Patch 4 or later is installed.

Upgrade is supported only if McAfee Host Intrusion Prevention 8.0 Patch 4 or later is installed.

Action ended 9:54:08: LaunchConditions. Return value 3.

However on other machines that ePO has successfully pushed HIPS to, I see a log similar to the following:

MSI (s) (8C:14) [12:22:28:740]: Doing action: LaunchConditions

Action ended 12:22:28: LogPackageInfo. Return value 1.

Action start 12:22:28: LaunchConditions.

MSI (s) (8C:14) [12:22:28:741]: Skipping action: BuildToBuildInstallError (condition is false)

MSI (s) (8C:14) [12:22:28:741]: Skipping action: CheckForInlineReinstall (condition is false)

MSI (s) (8C:14) [12:22:28:741]: Skipping action: InvalidInlineError (condition is false)

MSI (s) (8C:14) [12:22:28:741]: Skipping action: NewerFoundError (condition is false)

MSI (s) (8C:14) [12:22:28:741]: Doing action: CheckForLegacyVersion

Action ended 12:22:28: LaunchConditions. Return value 1.

Any advice/assistance is greatly appreciated.

7 Replies
Highlighted
Level 7
Report Inappropriate Content
Message 2 of 8

Re: HIPS Install from ePO error

silly question but... same package being deployed to successful and non-successful?

Highlighted
Level 7
Report Inappropriate Content
Message 3 of 8

Re: HIPS Install from ePO error

Yup, same package.

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 8

Re: HIPS Install from ePO error

It sounds like HIPS is already installed, or at least partially installed.  You'll probably want to open a Service Request (if available) for have this reviewed further and/or obtain the Removal tool to completely remove HIPS from the system.

Level 7
Report Inappropriate Content
Message 5 of 8

Re: HIPS Install from ePO error

The advice I received from support (so far) is that it the Return 3 code is related to syscore being broken in either the McAfee Agent or VSE that is already installed. They suggested removing all products and re-installing. Not ideal if I see this on a larger pool, but that is going to be my next step.

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 8

Re: HIPS Install from ePO error

Return value 3 simply means a specific installer action failed which triggers installation termination.  That specifically does not point to Syscore being broken on the system.  The failure (as far as I can see) is that the HIPS 8 P8 installer is detecting that HIPS 8.0 P0 to P3 is installed, therefore cancels the install (due to this prereq).  The HIPS 8 P8 release notes state that Patch4 is the requirement for an upgrade; a fresh install of HIPS 8.0 does not have this requirement though.

McAfee Corporate KB - Host Intrusion Prevention 8.0 Patch 8 Release Notes PD26623

This release includes these items:

• Patch — Updates McAfee Host IPS 8.0.0 clients running Patch 4 and later.

• Full installation — Includes the full McAfee Host IPS installation for new clients

Highlighted
Level 7
Report Inappropriate Content
Message 7 of 8

Re: HIPS Install from ePO error

That'st where it's confusing, because the system has never had HIPS. This was a fresh full install.

Highlighted
Level 7
Report Inappropriate Content
Message 8 of 8

Re: HIPS Install from ePO error

On a machine throwing this error (also a machine you have not tried to install if possible), check the registry and see if there are any entries in the reg specific to HIPS. If so, can you provide a screenshot?

HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community