cancel
Showing results for 
Search instead for 
Did you mean: 
mrwh1t3
Level 9

HIPS 7.0 Firewall Rules not pulling down

Jump to solution

All,

I have a test group where I am testing the deployment of HBSS on Windows 7 x64 Enterprise.

I have a Test_Workstation policy where I have built the firewall rules for these specific boxes, and now I am looking at enabeling the firewall and going full up and see if I missed anything in the process.

The issue I have is that the policy doesn't seem to be taking. If I pull up the McAfee HIPs window on the client and look at the firewall tab it still shows my firewall as not being enabled (no check mark there), and NONE of the rules I created in the test Test_Workstation policy seem to going to the clients.

Do you have any ideas on this one? So far neither of the two boxes will pull down the firewall policy I created. I've checked the inheritance and what not and that all looks fine. I've also reinstalled HIPS on the clients thinking that it might be an issue with the install. Still nothing.

0 Kudos
1 Solution

Accepted Solutions
mrwh1t3
Level 9

Re: HIPS 7.0 Firewall Rules not pulling down

Jump to solution

I upgraded to HIPS 8 and it works fine now. I couldn't get it working with 7 (no matter the patch level).

0 Kudos
5 Replies
McAfee Employee

Re: HIPS 7.0 Firewall Rules not pulling down

Jump to solution

1. Make sure the HIPS Client UI is locked (or closed).

2. If you have set the McAfee Agent tray icon to Disable IPS, Disable Firewall, or Disable App Blocking, use the Restore Settings options.

With either of these two issues, the McAfee Agent will not enforce HIPS policies (as designed).

3. In the ePO server console, use the Modify policies on single system option and view the system's policy assignments.  Verify that the Enforcement Status (option next to the Host Intrusion Prevention 7.0 product listing) is set to Enforcing.

If these do not resolve it, I would suggest contacting McAfee Support for further troubleshooting.

0 Kudos
mrwh1t3
Level 9

Re: HIPS 7.0 Firewall Rules not pulling down

Jump to solution

So it's looking more and more like a "Windows 7" problem. I went ahead and moved one of our extra servers into this group just to test it out, and it appears to pull down the firewall rules without any problems. The server I used was Windows 2008 R2. It pulled them down on the first try.

I'm wondering if it's a GPO, etc. issue on the Windows 7 box. Thoughts?

0 Kudos
mrwh1t3
Level 9

Re: HIPS 7.0 Firewall Rules not pulling down

Jump to solution

I might also add that I just tested on Windows Vista and it worked fine. Do you know if there are issues with HIPS 7 with Patch 8 and Windows 7 x64?

0 Kudos
McAfee Employee

Re: HIPS 7.0 Firewall Rules not pulling down

Jump to solution

Ensure you are running the latest HIPS 7.0 extension (7.0.5) on your ePO server.

KB65844 - Host Intrusion Prevention 7.0 Support for Windows 7 and Server 2008

0 Kudos
mrwh1t3
Level 9

Re: HIPS 7.0 Firewall Rules not pulling down

Jump to solution

I upgraded to HIPS 8 and it works fine now. I couldn't get it working with 7 (no matter the patch level).

0 Kudos