cancel
Showing results for 
Search instead for 
Did you mean: 

Can Not Install HIPS 7.0

Hello,

I'm trying to install hips version 7.0.0 minor 833 on one of my server (OS Windows 2003 Server 5.2 Service Pack 2 ). Remote installation from my ePo server 4.0 did not work.

Therefore, I have decided to launch manual installation. But I get error "Error 1406. Could not write value LanguageID to key \SOFTWARE\McAfee\HIP . Verify that you have sufficient access to that key, or contact your support personnel."

I uninstalled manually HIPS following mcafee procedure , rebooted the server and tried to reinstall again but got the same error.

I launched "Process Monitor" application to check processes which read/write in the key \SOFTWARE\McAfee\HIP  during HIPS installation but I found only processus msiexe.exe which installed HIPS.

Could you help me troubleshooting and fixing this issue ?

Thanks in advance

Ghislaine

0 Kudos
5 Replies
McAfee Employee

Re: Can Not Install HIPS 7.0

Can you duplicate the behavior with the most current HIPS 7 Patch 7 repost (i.e., HIPS 7 packaged with Patch 7 rolled in) ?

0 Kudos
bgable
Level 11

Re: Can Not Install HIPS 7.0

http://msdn.microsoft.com/en-us/library/aa372835(VS.85).aspx

Are you running Credent Mobile Guardian or similar?

We have seen this occur.

If so, disable Credent and try to uninstall again.

If not Credent, check if you have some other disk encryption or data protection product running on the server.

Additionaly, you could verify interactively that you can write or create the following key:

write value LanguageID to key \SOFTWARE\McAfee\HIP

Both with an admin account and the local system account (you can use the AT scheduler command)

0 Kudos
mcGEE
Level 7

Re: Can Not Install HIPS 7.0

By any chance are you running VirusScan on this server?  If so, you may need to disable Access Protection temporarily because by default it prevents the execution of files from the windows temp directory and may prevent the modification of the registry

G.

Message was edited by: mcGEE on 3/24/10 10:05:49 PM CDT
0 Kudos

Re: Can Not Install HIPS 7.0

Hello ,

Thanks all for your information.

I have uninstalled manually HIPS with the procedure describes on url https://kc.mcafee.com/corporate/index?page=content&id=KB51699 ; but I think that uninstallation is not complete.

In fact I can see in "Add remove Program" of my server an entry about HIPS. When I try to uninstall it from "Add remove Program", I get error "Product is in self-protected mode. Please disable self-protect mode before uninstalling".

I think that this problem is due to the fact that I have not disable IPS module before the manual uninstallation.

I don't know how to disable self-protected mode since I can not modify IPS module configuration . In fact due to manuel uninstallation, I hare removed HIPS installation directory and HIPS client can not communicate anymore with ePO. 

How can I uninstall completely the old version of HIPS in order to reinstall it ?


Thanks in advance for your help

Ghislaine

0 Kudos
bgable
Level 11

Re: Can Not Install HIPS 7.0

KB51699

0 Kudos