Showing results for 
Search instead for 
Did you mean: 
Level 10

EMM and Android 2.3


Can anyone please verify if they have EMM working on Android 2.3 OS?

We currently have a few users with Verizon Droid X devices that recently upgraded to Android 2.3 via a new OTA update from Verizon. When the phones were on version 2.2 they worked flawlessly. Once upgraded they will not connect to our EMM server.

Our EMM system is setup as the Enhanced Security Model with a DMZ proxy and an internal hub. iOS, iPADs and iPhones work fine. Android 2.2 devices work fine.

When attempting to connect to our EMM server the device receives the error "Error adding account. Login to the account failed, please try again. OK.". The user and password are definitely correct as they connect to our Activesync server directly without issue.

Here are a few troubleshooting steps I can state:

  • Droid X with 2.2 can still connect to EMM server, as do iOS devices.
  • I've tried removing EMM from the Android and reinstalling and also removing all email profiles and reconfiguring without success.
  • Connection fails over 3G and WiFi connections.
  • I've installed Wireshark on the EMM proxy(DMZ) server and can see the attempt being made from the device, so I'm pretty sure it is not a firewall issue.
  • If I point the Android 2.3 device directly to our Activesync email server (bypassing EMM) it connects without issue.
  • EMM is at the most current version with the current device catalog installed (as of the date of this posting 6/5/11)

As I stated before, everything has been working fine until the new Android OS update.

Any recommended troubleshooting, thoughts or comments will be greatly appreciated.

I have not called into McAfee support yet as I have not had time and have previously found their EMM support lacking.

Thank you,


0 Kudos
43 Replies
Level 9

Re: EMM and Android 2.3


Have you tried wiping the device, deleting from EMM, and reloading the EMM app? After you have wiped the phone, try and updating the phone first following the installation of EMM. This is just a suggestion. I haven't came across that issue and also not looking forward to it. Let me know if you were successful.



0 Kudos
Level 10

Re: EMM and Android 2.3

Hi Junior,

Wiping the device did not help with the issue.

Personally I would like to throw the Droids in the garbage.

Can anyone please confirm that they have EMM working on Android 2.3?



0 Kudos
Level 9

Re: EMM and Android 2.3


It may be that the Device Catalog needs updating. Have a look at page 39 of the EMM Product Guide (Viewing and Adding a Device Catalog):


0 Kudos
Level 10

Re: EMM and Android 2.3

Hi Adroit,

As I said in my post I have the latest device catalog and I check often for updated catalogs.

Maybe it is just an issue with the Droid X model. I do not have any other Android 2.3 models to test.

I will attempt to open up a service call with McAfee support this week as no on has been able to confirm that they have EMM working with Android 2.3 in their environment. I'm not looking forward to being on hold for 3 hours like the last time I needed EMM support.


0 Kudos

Re: EMM and Android 2.3

Any answer to this question?  I have the same situation.

0 Kudos
Level 10

Re: EMM and Android 2.3

I have not got answer yet. Have had a case open with McAfee for 2 weeks. I'm sorry but I am glad to hear I am not the only one...not that I wish anyone else trouble, but maybe if multiple people have the issue they will address it faster.

When troubleshooting with McAfee they showed me a couple of interesting events in the log. It looks like EMM cant handled the input fom one of the fields from the Droid X with 2.3 OS or it is missing a field.

Log Name:      McAfee EMM

Source:        EAS Filter

Date:          7/31/2011 5:49:04 PM

Event ID:      0

Task Category: None

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      EMM


FilterAuthentication.IsCompliant Error due to one or more null inputs

Event Xml:

<Event xmlns="">


    <Provider Name="EAS Filter" />

    <EventID Qualifiers="0">0</EventID>




    <TimeCreated SystemTime="2011-07-31T21:49:04.000Z" />


    <Channel>McAfee EMM</Channel>


    <Security />



    <Data>FilterAuthentication.IsCompliant Error due to one or more null inputs</Data>



I will share my case number so that you can have them reference it if you call into support:

McAfee case# SR # 3-162602687

On another note EMM works crappy on Android Motorola Xoom running 3.0 OS. Issues openning attachments and logging into EMM Application.

I would like to ask everyone with EMM and Androids one additional question. Are each Android device taking 2 EMM licenses, 1 from EMM App and one from connecting email? Mine is using 2 license per Android.

0 Kudos
Level 7

Re: EMM and Android 2.3

We have just started using EMM and are having this issue as well. it installs fine on their android, but no mail appear... in EMM it also displays the android as being NOT compliant.

we didn't try the androids using 2.2, but they have 2.3 so would like to move forward... 

hopefully McAfee comes back to you soon.

0 Kudos
Level 7

Re: EMM and Android 2.3

What Anroid device are you trying to provision cariesp? I've got exactly your problem with my Samsung Galaxy S Plus device.  it seems bo different from Joey's problem. As long as it's a general Android 2.3 issue, the catalog will help us out. If it is not, we still have our problem.

This is what is listed in the event log coming from the EAS Filter. Even after I used compliance override!

Device with DeviceId = validate, User = test, DeviceType = SAMSUNGGTI9001 is Not Compliant

Message was edited by: tomverboon on 8/12/11 3:30:40 AM CDT
0 Kudos
Level 9

Re: EMM and Android 2.3

I have the same issue : Device with DeviceId = validate, User = ***, DeviceType = SAMSUNGGTI9000 is Not Compliant

I have the lates device catalog installed: 37007

Someone manage to resolve this issue?

Edit: Android 2.3.5

Message was edited by: mrt on 9/19/11 4:40:03 AM CDT
0 Kudos