cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 3

EMM Hub and ePO Server Unable to Communicate

Jump to solution

Up until today, communication between my EMM 12.0.5 Internal Hub (running on Server 2012 R2) and the ePO server has worked just fine. Suddenly, every time I navigate to Server Settings > Enterprise Mobility Management in ePO, I immediately get "Unknown error has occurred". It is apparently unable to retrieve the settings from the Hub.

Looking at the Event Viewer on the Hub, I am now seeing this:

WebHost failed to process a request.

Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/5593166

Exception: System.ServiceModel.ServiceActivationException: The service '/EMMHub/PushNotifierGateway.svc' cannot be activated due to an exception during compilation.  The exception message is: Could not load file or assembly 'App_Web_bai-fzzs, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.. ---> System.IO.FileNotFoundException: Could not load file or assembly 'App_Web_bai-fzzs, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

File name: 'App_Web_bai-fzzs, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'

   at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)

   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

   at System.Reflection.Assembly.Load(String assemblyString)

   at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses)

   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.CreateService(String normalizedVirtualPath)

   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)

   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

   --- End of inner exception stack trace ---

   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)

   at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)

Process Name: w3wp

Process ID: 4252

I cannot figure out what has changed in the last couple of days. I was wondering if anyone else has seen this message, or have any idea where it originates and how you resolved it?

Any guidance you can provide would be greatly appreciated!

1 Solution

Accepted Solutions
Former Member
Not applicable
Report Inappropriate Content
Message 3 of 3

Re: EMM Hub and ePO Server Unable to Communicate

Jump to solution

Restarting the Hub and ePO did not resolve it, but McAfee KB 83370 did:

https://kb.mcafee.com/agent/index?page=content&id=KB83370

View solution in original post

2 Replies
Former Member
Not applicable
Report Inappropriate Content
Message 2 of 3

Re: EMM Hub and ePO Server Unable to Communicate

Jump to solution

Most probably,this issue will fix after rebooting the EMM hub server.

Former Member
Not applicable
Report Inappropriate Content
Message 3 of 3

Re: EMM Hub and ePO Server Unable to Communicate

Jump to solution

Restarting the Hub and ePO did not resolve it, but McAfee KB 83370 did:

https://kb.mcafee.com/agent/index?page=content&id=KB83370

View solution in original post

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community