cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 13

ePolicy Orchestrator is not deploying the Agent on Clients PC

* Server: ePolicy Orchestrator 4.0.0 (Build: 1151)
* VirusScan® Enterprise 8.7i
* SiteAdvisor 2.0
* AntiSpyware Enterprise Module 8.7

- McAfee Agent for Windows 4.0.0
- Engine 5301.4018

----------------------------------------------------

Clients O.S.: Windows XP PRO SP3
everything was working fine ..
all firewalls are disable on the client PC's
ePolicy Orchestrator is not syncing with them

when i open the ePO: Compliance Summary
only 18 Compliant - 0 Non-Compliant (Company Pc's over 40 PC)

any help just to discover the problem !?
Labels (1)
12 Replies
Former Member
Not applicable
Report Inappropriate Content
Message 2 of 13

RE: ePolicy Orchestrator is not deploying the Agent on Clients PC

When you say "not syncing" do you mean that the agent isn't checking into the ePO, VirusScan is not pulling DAT updates from the ePO, or both? Several questions, assuming an agent issue...

1. How was the agent installed on the machines that aren't communicating with the ePO? (manually vs. pushed from the ePO)
2. Do the remaining 22 computers show up in the ePO as unmanaged?
3. Does the agent respond on port 8081 when attempting a connection through a web browser? (assuming your policy allows it)
4. Are you able to ping the ePO from the client computers that aren't communicating?
5. Are you able to telnet to port 81 on the ePO from these clients?
6. Does the Agent Monitor allow you to "Collect and Send Props" manually from a client?
Former Member
Not applicable
Report Inappropriate Content
Message 3 of 13

RE: ePolicy Orchestrator is not deploying the Agent on Clients PC

Former Member
Not applicable
Report Inappropriate Content
Message 4 of 13

RE: ePolicy Orchestrator is not deploying the Agent on Clients PC

Hi

On the last point, run ‘CmdAgent.exe /s’ in the McAfee Common Framework folder and then click the buttons to perform each function.
Former Member
Not applicable
Report Inappropriate Content
Message 5 of 13

RE: ePolicy Orchestrator is not deploying the Agent on Clients PC

Former Member
Not applicable
Report Inappropriate Content
Message 6 of 13

RE: ePolicy Orchestrator is not deploying the Agent on Clients PC

Hi

You will need to have administrator privs and put the full path into the run box, what I do is open explorer and find the file, then open a run box and delete whats in there, then left mouse button drag and drop the file to the run box, then go to the end and put a space then /s, finally click ok.
Former Member
Not applicable
Report Inappropriate Content
Message 7 of 13

RE: ePolicy Orchestrator is not deploying the Agent on Clients PC



ok i tried it .. not working
note: i have administrator permission

1- C:\Program Files\McAfee\Common Framework\CmdAgent.exe /s

2- C:\Program Files\McAfee\Common Framework\CmdAgent.exe/s

3- "C:\Program Files\McAfee\Common Framework\CmdAgent.exe" /s

4- "C:\Program Files\McAfee\Common Framework\CmdAgent.exe/s"

5- "C:\Program Files\McAfee\Common Framework\CmdAgent.exe /s"


i type all this commands in the run command ..

Show error
Windows cannot find 'c:\program'. make sure you type the name correctly
Former Member
Not applicable
Report Inappropriate Content
Message 8 of 13

RE: ePolicy Orchestrator is not deploying the Agent on Clients PC

Hi

I will try to respond later as a bit busy just now, number 3 is the one that should work, command inside quotes and the parameter outside.
If this is not working you may need to reinstall Framepackage.

I will try to get back on a little later and explain process or point you at a KB article, it basically is FRMINST.EXE /FORCEUNINSTALL and then push the agent again but you may need to remove files and registry entries as well.

Good luck, talk to you later
Former Member
Not applicable
Report Inappropriate Content
Message 9 of 13

RE: ePolicy Orchestrator is not deploying the Agent on Clients PC

Former Member
Not applicable
Report Inappropriate Content
Message 10 of 13

RE: ePolicy Orchestrator is not deploying the Agent on Clients PC



Also, if you are upgrading a really old version, the "McAfee" folder may be "Network Associates".
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community