cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 9
Report Inappropriate Content
Message 1 of 8

ePO4 to ePO4.5 ugprade broke Apache

Hello all,

I upgraded our ePO4 (patch4) to ePO4.5 today and all seemed to go fine.
However, upon restarting the server I see that the "McAfee ePolicy Orchestrator 4.5.0 Server" service doesn't start.

The Application event log has an entry for;

EventID: 3299
Source: Apache Service
Description: "The Apache service named reported the following error: >>> Unable to open logs"

The System Event Log has an entry for;

EventID: 7024
Source: Service Control Manager
Description: The McAfee ePolicy Orchestrator 4.5.0 Server service terminated with service-specific error 1 (0x1).

There are no apache logfiles (no files at all actually) in the [E:\APPS\ePolicy Orchestrator\Apache2\Logs] folder. It can't be a permissions thing because the services are set to run under System account which has the default full access permissions to this location

I've searched the known issues with epo4.5 and the mcafee knowledgebase but can't find any useful help thus I'm posting here.

Any suggestions ? The clients are not able to communicate to the server on port 82 now. They were working on this port fine before the ugprade. I've changed nothing.
7 Replies
Highlighted
Level 11
Report Inappropriate Content
Message 2 of 8

RE: ePO4 to ePO4.5 ugprade broke Apache

do you have anything that uses port 443 on the epo server? are you using the server for something else....do a netstat -an at the dos prompt and see if anything is listening on your asci port or 443. apache will not start if something else is using its port.
Highlighted
Level 9
Report Inappropriate Content
Message 3 of 8

RE: ePO4 to ePO4.5 ugprade broke Apache

Hi djjava9, thanks for your response.

The netstat -an does report that there is something listening on port 443 so I guess that explains that. I've now checked this and we have the webhelpdesk service for the mcafee endpoint encryption running on this port. I will have to reconfigure it to use a different port ... this is probably the easiest solution.

I don't understand why the upgrade to ePO4.5 would show this problem now though since ePO4 and EnpointEncryption co-existed happily before this.

Thanks!
Highlighted
Level 9
Report Inappropriate Content
Message 4 of 8

Re: RE: ePO4 to ePO4.5 ugprade broke Apache

Hi Guys,

I Searching about this error and encountered this topic. After I encountered this article:

https://kc.mcafee.com/corporate/index?page=content&id=KB66929&pmv=print

This arcticle help me a lot.

I hope it was useful to someone.

Hugs

on 24/08/10 1:29:44 BRT PM
Highlighted
Level 9
Report Inappropriate Content
Message 5 of 8

Re: RE: ePO4 to ePO4.5 ugprade broke Apache

Hi thiago,

I had totally forgotten about this thread I started!

You are completely right, the solution was to change the ports.  Thanks for posting the link.

Highlighted
Level 9
Report Inappropriate Content
Message 6 of 8

Re: RE: ePO4 to ePO4.5 ugprade broke Apache

Hi Erinc,

Not at all,

Hugs.

Highlighted

Re: RE: ePO4 to ePO4.5 ugprade broke Apache

I have just upgraded  to ePO4.5 and after restarting the server the two services Mcafee  Epolicy Orchestrator 4.5.0 server and Mcafee epolicy orchestrator 4.5.0 event parser have brought the errors as in this post. The difference here is that I dont have any other application using port 443. The netstat results are attached. what might have caused the services not to restart.

Anybody whom have had this problem before, please advice

Highlighted

Re: RE: ePO4 to ePO4.5 ugprade broke Apache

Im having the nearly the same problem as the one u posted here but the difference is that in my case there is nothing running on port 443 and the netstat results are attached. any advice

The errors on the services named are the same and logs too

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community