cancel
Showing results for 
Search instead for 
Did you mean: 
Level 8
Report Inappropriate Content
Message 1 of 6

Unable to install Agent

I am unable to deploy agent on a machine, we have many machines on that site which have agent installed, but installation on this machine comes back with an err code =53.

Please help

5 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 6

Re: Unable to install Agent

Have a look into "c:\windows\temp\mcafeelogs" for the installation log files or post the log or snippets here so the whole error can be seen within its context in the logs.

Highlighted
Level 8
Report Inappropriate Content
Message 3 of 6

Re: Unable to install Agent

I dont see the latest logs on the targetted machine, its all old logs i seeMcafee123.JPG

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: Unable to install Agent

If the installer is executed in a user context (locally on the machine), i.e. adminstrator, logs would be located in this specific users temp folder (%usertemp%\McAfeeLogs). Although I read your initial post as having some automated means to deploy the package (reading, ePO). If there are no logs the install is not even starting, I wonder where you observe the error that you have described. When you deploy the agent from ePO, the first thing that will happen is that the ePO server will attempt to drop the framepkg executable into c:\windows of the target machine, from here its executed and installed. Inability to open the adminstrative share (C$) from ePO (to drop the exectuable) will result in failure without a log file being created/written for example.

Try to describe the sequence of events and where in this sequence you see that 53 error, presently its not clear when exactly that error occurs.

Highlighted
Level 8
Report Inappropriate Content
Message 5 of 6

Re: Unable to install Agent

@sbenedix I see the error in DB folder on ePO server itself, i am unable to open the Admin$ however there are thousands of machine i cannot see admin$ sill i am able to deploy on those machines. below are the logs i see in DB folder server_server name:

 

PushAgent.cpp(293): Push Agent Installation Program to MachineName failed

PushAgent.cpp(176): Failed to authenticate to \\MachineName, err=53

 

 

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 6

Re: Unable to install Agent

Hmm, the failure state is clear then, although the error messages seemingly describe 2 different things. 

You have for one: failed to authenticate (that is clear) and for two you have error 53, which is documented here: https://docs.microsoft.com/en-us/windows/desktop/debug/system-error-codes--0-499-, thus your install attempt fails at the stage when ePO itries to push down the framepkg to the target machine, the path is not accessible. Both errors should provide good enough leads for further research on your end. What is different to the rest of your estate is anybodies guess at this stage.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community