Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7
Report Inappropriate Content
Message 1 of 2

McAfee Agent installation FAILS via script on OS Catalina

We are using McAfee Agent script downloaded from our GPO according to the first installation of McAfee Agent on our Mac OS hosts.
Installation takes please according to the MDM solution.

Agent version in our production is

The installation process worked correctly (on Mojave and High Siera) till we began to do the first (clean) install of McAfee Agent on Mac OS Catalina.
From that time we are getting the same problem on every host with OS Catalina on board.
Please see the ERROR log below:
Script result: bit-64
mktemp: mkdtemp failed on mfezPC5ih: Read-only file system mkdir: : No such file or directory Aug 5 20:23:20 installer[13549] <Critical>: PFPkg: No file found at path: /ma.pkg Aug 5 20:23:20 installer[13549] <Critical>: PFPackage::packageWithURL - can't instantiate package: /ma.pkg installer: Error - the package path specified was invalid: 'ma.pkg'. hdiutil: detach failed - No such file or directory
We have tried to fix the problem according to the recommendation mentioned in

But without any results. The problem still appears.

We track that installation. sh script can't do "...mktemp -d /Volumes/MFEMA..." operation so can't run any farther actions.

For to debag possibility of any problems connected to the Agent version and Mac OS Catalina same installation were tested for the latest McAfee Agent 5.6.5 Hotfix 2
The problem still appears only on Mac OS Catalina. All previous Mac OS versions according to McAfee compatibility list worked correctly without any errors with Agent 5.6.3/5.6.4/5.6.5

In spite of this, we can do the manual installation of any mentioned McAfee Agent ver only from Terminal mod to Mac OS Catalina after:

sudo chmod +x
sudo ./ -i
As mentioned in

According to the community discussion, this problem is similar not only for our organization.

Could you please give advice about any possible solution to the problem?

1 Reply

Re: McAfee Agent installation FAILS via script on OS Catalina

Is there any solution availible for this problem?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community