Showing results for 
Search instead for 
Did you mean: 
Level 7

issues upgrading from ENS 10.5 to 10.5.1

is there a special why to upgrade to ENS 10.5.1? we currently have 10.5 installed in the enviroment. i built a client task for the new ENS 10.5.1 packages and when i run that client task on a test systems i get his error in the Agent Status Monitor: installed module is neither in perpetual mode nor in evaluation mode

is there a special way to upgrade 10.5 to the new patch?

0 Kudos
5 Replies
Level 9

Re: issues upgrading from ENS 10.5 to 10.5.1

Please find the product doc that contains info you were looking for.

McAfee Corporate KB - Endpoint Security 10.5.1 Release Notes PD26909

0 Kudos
Level 7

Re: issues upgrading from ENS 10.5 to 10.5.1

Thanks but referring to the ReadMe is not an answer, thanks for playing.

ISSUE: After moving ENS 10.5.1 from the evaluation branch (from which I had used to deploy 10.5.1 or update 10.5.0 to 10.5.1 without issue for several thousand machines) to the current branch, all my attempts at updating 10.5.0 now fail with the message: Installed module is neither in perpetual mode nor in evaluation mode. Since everything was working before the branch change this is an issue that needs an answer...thanks

0 Kudos
Level 10

Re: issues upgrading from ENS 10.5 to 10.5.1

If you get this: "Installed module is neither in Perpetual mode nor in Evaluation mode" (assuming you are using on premise ePO not cloud ePO), it may be a quirk in the detection script, please raise a service request with McAfee Support. The "Installed module is neither in Perpetual mode nor in Evaluation mode" can be observed in the agent monitor (cmdagent /s) and also in the script engine log file McScript.log file (C:\Users\All Users\McAfee\Agent\logs).

Reference the following ID: 1200936 when opening a Service Request.

Provide the following logs alongside:

01. Enable MA Debug Logging (KB82170, per ePO policy) and McScript Debug Logging (KB82170, per registry), set appropriate logsizes (100 MB for good measure) on one affected machine, make sure to sent an agent wakeup so changes to logging are applied

02. Download AmTrace, KB86691 (its attached to the bottom of the article, how to use is described in the article too)

03. start AmTrace from the directory respective to your OS, x64/x86

- amtrace --start

04. run the update task, will fail

05. stop AmTrace

- amtrace --stop

06. run MER, selecting MA and ENS (+ any other products that may be installed) manually from the list of available products (

07. gather MER, created *.etl from AmTrace run (compress if required), attach to your SR

If you do not get "Installed module is neither in Perpetual mode nor in Evaluation mode" it is something different, the above data set would still help to shed some light into the issue though.

You can try to clean out all traces of ENS from your repository (delete all related packages, HFs, patches, install packages etc.), check the main package and patch packages (not any Hotfixes for the time being) back into the ePO repository  (this will remove all detection scripts in a controlled fashion and re-add them), replicate to any distributed repos if required. Try redeploy/update. Deleting Extensions is not required.

0 Kudos
Level 7

Re: issues upgrading from ENS 10.5 to 10.5.1

I just ran into this issue in a couple of my lab machines, and here is what happened prior and what I found to work around it.

- I had somehow upgraded Adaptive Threat Protection to

- Agent updated to

Every time I ran into this issue, the system had the above mentioned, DXL 3.0.1 and ENS 10.5.0 platform and threat prevention installed and basic windows (Lab machines). In order to get this resolved, I did the following:

  1. Run a client task on the effected machine to uninstall Adaptive Threat Protection, then Threat Prevention, then the Platform
    1. The order matters!
    2. It can use the 10.5.1 installation packages to do this in my experience
    3. This could probably be done physically at the endpoint if you know the uninstall password.
  2. Run a client task on the freshly uninstalled machine to install the Platform, then Threat Prevention, then Adaptive Threat Protection
    1. The order matters!

Hope this helps anyone else experiencing this issue.

0 Kudos
Level 7

Re: issues upgrading from ENS 10.5 to 10.5.1

Not sure if this will help you or not. Maybe by now you already figured it out but we had issues moving from 10.5.0 to 10.5.1. The reason was that there is an issue with deployment tasks and 10.5.1 when the install and the Hotfix for 10.5.1 are in the same branch. If you have yours set the same way as I did where 10.5.1 and the Hotfixes were both in Current then the tasks fail/never run.

I followed the workaround instructions in this KB and my 10.5.1 install tasks started to work.

McAfee Corporate KB - Upgrade from Endpoint Security 10.5.0 to 10.5.1 fails if 10.5.1 Hotfix 1/Hotfi...