cancel
Showing results for 
Search instead for 
Did you mean: 

installation failed!! return code : 1603

Jump to solution

I downloaded the "McAfee_Endpoint_Security_10_6_0_357_13_epo_enterprise_evaluation" but failed to install "Threat_Prevention_10_6_0_672_4_client".

Does anyone know how to fix this error?

I found this KB but it did not work, this KB does not work.
https://kc.mcafee.com/corporate/index?page=content&id=KB85033ePO_error_1603.PNG

 

10/09/2018 11:04:10.288 [860] [BootstrapperMain] ThreatPrevention:Product version :10.6.0
10/09/2018 11:04:10.288 [860] [BootstrapperMain] ThreatPrevention:Build number - 672 , Package number - 4
10/09/2018 11:04:10.288 [860] [BootstrapperMain] Uninstall String found for {FF94B30D-A51E-4D68-A353-0667C5655D2E}
10/09/2018 11:04:10.303 [860] [BootstrapperMain] GetInstallLocation start >>
10/09/2018 11:04:10.303 [860] [BootstrapperMain] GetInstallLocation - szUninstallKey = SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{FF94B30D-A51E-4D68-A353-0667C5655D2E}
10/09/2018 11:04:10.303 [860] [BootstrapperMain] GetInstallLocation - RegOpenKeyEx succeeded.
10/09/2018 11:04:10.303 [860] [BootstrapperMain] GetInstallLocation - InstallLocation = C:\Program Files\McAfee\Endpoint Security\
10/09/2018 11:04:10.319 [860] [BootstrapperMain] Unable to read RunAppInfo.xml. No bundled app installation will be performed.
10/09/2018 11:04:10.319 [860] [BootstrapperMain] Commandline:
10/09/2018 11:04:10.319 [860] [BootstrapperMain] Uninstall String found for {FF94B30D-A51E-4D68-A353-0667C5655D2E}
10/09/2018 11:04:10.319 [860] [BootstrapperMain] GetInstallLocation start >>
10/09/2018 11:04:10.335 [860] [BootstrapperMain] GetInstallLocation - szUninstallKey = SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{FF94B30D-A51E-4D68-A353-0667C5655D2E}
10/09/2018 11:04:10.335 [860] [BootstrapperMain] GetInstallLocation - RegOpenKeyEx succeeded.
10/09/2018 11:04:10.335 [860] [BootstrapperMain] GetInstallLocation - InstallLocation = C:\Program Files\McAfee\Endpoint Security\
10/09/2018 11:04:10.335 [860] [BootstrapperMain] Commandline:
10/09/2018 11:04:10.350 [860] [BootstrapperMain] Free Space in Drive 'C:': 193499484 Kb
10/09/2018 11:04:10.350 [860] [BootstrapperMain] ThreatPrevention:Build number - 672 , Package number - 4
10/09/2018 11:04:10.350 [860] [BootstrapperMain] Patch version of ESP to Check is 0
10/09/2018 11:04:10.350 [860] [BootstrapperMain] No patch check required
10/09/2018 11:04:10.366 [860] [BootstrapperMain] Certificate file does not exist in local path of bootstrapper. So, not updating certificate
10/09/2018 11:04:10.366 [860] [BootstrapperMain] Build to Build upgrade has not been attempted on the system. Hence proceeding with preserve settings.
10/09/2018 11:04:10.366 [860] [BootstrapperMain] ENS common is there on the system. Let us get exclusion before proceeding further!
10/09/2018 11:04:10.381 [860] [BootstrapperMain] Extracting MfeEpAac_mfeprotect.exe : C:\Users\TONY~1.STA\AppData\Local\Temp\MfeEpAac_mfeprotect.exe
10/09/2018 11:04:10.459 [860] [BootstrapperMain] Extraction successful
10/09/2018 11:04:10.459 [860] [BootstrapperMain] This is a 64 bit system
10/09/2018 11:04:10.459 [860] [BootstrapperMain] "C:\Users\TONY~1.STA\AppData\Local\Temp\MfeEpAac_mfeprotect.exe" -add -rootlocation "C:\Program Files\McAfee\Endpoint Security" -rootlocation "C:\Program Files (x86)\McAfee\Endpoint Security" -folder "C:\ProgramData\McAfee\Endpoint Security"
10/09/2018 11:04:10.459 [860] [BootstrapperMain] RunCommandLine: "C:\Users\TONY~1.STA\AppData\Local\Temp\MfeEpAac_mfeprotect.exe" -add -rootlocation "C:\Program Files\McAfee\Endpoint Security" -rootlocation "C:\Program Files (x86)\McAfee\Endpoint Security" -folder "C:\ProgramData\McAfee\Endpoint Security"
10/09/2018 11:04:10.647 [860] [BootstrapperMain] RunCommandLine: Process return code : 0
10/09/2018 11:04:10.647 [860] [BootstrapperMain] Running application to gain installer exclusion succeeded.
10/09/2018 11:04:10.663 [860] [BootstrapperMain] Solidcore not found. Installation proceeds further.
10/09/2018 11:04:10.663 [860] [BootstrapperMain] Migration_Plugins.zip not available. Module installations donot need this. Proceeding further.
10/09/2018 11:04:10.663 [860] [BootstrapperMain] Checking for older ENS product
10/09/2018 11:04:10.678 [860] [BootstrapperMain] Did not find a ENS product matching the upgrade code of this product. Proceeding further.
10/09/2018 11:04:11.37 [860] [BootstrapperMain] Locale Obtained 1033
10/09/2018 11:04:11.37 [860] [BootstrapperMain] msiexec.exe /i"C:\Users\tony.stark\Downloads\McAfee_Endpoint_Security_10_6_0_357_13_epo_enterprise_evaluation\Threat_Prevention_10_6_0_672_4_client\McAfee_Threat_Prevention_x64.msi" TRANSFORMS="C:\Windows\Temp\McAfeeTmpMSTPath\1033.mst" /qn /norestart BOOTSTRAPPERCALL=1 QUARANTINEFOLDER=NOTPROVIDED /l*v "C:\Users\TONY~1.STA\AppData\Local\Temp\\McAfeeLogs\McAfee_ThreatPrevention_Install_10092018110410319.log" INSTALLDIR="C:\Program Files\McAfee\Endpoint Security\" PACKAGEDAMCORE=1.5.0.5002.8
10/09/2018 11:04:11.53 [860] [BootstrapperMain] PrepareAMCoreInstallationFiles: Engine Directory : C:\Program Files (x86)\Common Files\McAfee\Engine
10/09/2018 11:04:11.53 [860] [BootstrapperMain] PrepareAMCoreInstallationFiles: AVSolution Directory : C:\Program Files (x86)\Common Files\McAfee\AVSolution
10/09/2018 11:04:11.53 [860] [BootstrapperMain] PrepareAMCoreInstallationFiles: Appended Engine cab to Temp Path successfully : C:\Users\TONY~1.STA\AppData\Local\Temp\AMCORE_OEM_CONTENT.CAB
10/09/2018 11:04:11.53 [860] [BootstrapperMain] PrepareAMCoreInstallationFiles: Path to copy AMCore Cab from: C:\Users\tony.stark\Downloads\McAfee_Endpoint_Security_10_6_0_357_13_epo_enterprise_evaluation\Threat_Prevention_10_6_0_672_4_client\\AMCORE_OEM_CONTENT.CAB
10/09/2018 11:04:11.69 [860] [BootstrapperMain] PrepareAMCoreInstallationFiles: Extracting AMCore installation files from 'C:\Users\tony.stark\Downloads\McAfee_Endpoint_Security_10_6_0_357_13_epo_enterprise_evaluation\Threat_Prevention_10_6_0_672_4_client\\AMCore_Install_64.zip' to 'C:\Users\tony.stark\Downloads\McAfee_Endpoint_Security_10_6_0_357_13_epo_enterprise_evaluation\Threat_Prevention_10_6_0_672_4_client\\PackagedAMCore'
10/09/2018 11:04:12.22 [860] [BootstrapperMain] Installing module
10/09/2018 11:06:59.538 [860] [BootstrapperMain] installation failed!! return code : 1603
10/09/2018 11:06:59.538 [860] [BootstrapperMain] CheckIfPreviousProductRemoved: Start
SUBKESY(SOFTWARE\McAfeeEndpointSecurity_ModuleRemovalTracker) KEYNAME(MajorUpgradeProductsCount)
10/09/2018 11:06:59.554 [860] [BootstrapperMain] bOldrPrdtUninstallState(0)
10/09/2018 11:06:59.554 [860] [BootstrapperMain] installation failed!! return code : 1603

1 Solution

Accepted Solutions
Highlighted
McAfee Employee BEllis
McAfee Employee
Report Inappropriate Content
Message 3 of 3

Re: installation failed!! return code : 1603

Jump to solution

There is a chance that there is some type of DLL injection causing failure. Again first we would need the first set of logs

Then check for

https://kc.mcafee.com/corporate/index?page=content&id=KB89239

 

 

McAfee Support

Benjamin Ellis

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

2 Replies
McAfee Employee sbenedix
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: installation failed!! return code : 1603

Jump to solution

One would need the full set installer logs to provide a complete assesment. However, you probably can arrive at some solid conclusion by following these quick steps.

 

What you need to know, return Values for MSI are (in part) documented here: https://docs.microsoft.com/en-us/windows/desktop/msi/logging-of-action-return-values

 

Equipped with the above we find that 1603 (overall) is "ERROR_INSTALL_FAILURE", a fatal error. Now, to determine where it went pear shaped, start from the top and search downwards for the corresponding "return value" which for a fatal error is: "3", as per above link. Searching from top to bottom of the MSI installer log (Bootsrapper log != MSI installer log), you should find the first instance of the failure and just prior you will see what the MSI installer was doing and did not work. Use key words from the actual failure to frisk "kb.mcafee.com" for known issues or your favourite search engine (startpage.com of course) to frisk the net, see what that yields.

Highlighted
McAfee Employee BEllis
McAfee Employee
Report Inappropriate Content
Message 3 of 3

Re: installation failed!! return code : 1603

Jump to solution

There is a chance that there is some type of DLL injection causing failure. Again first we would need the first set of logs

Then check for

https://kc.mcafee.com/corporate/index?page=content&id=KB89239

 

 

McAfee Support

Benjamin Ellis

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community