cancel
Showing results for 
Search instead for 
Did you mean: 

cygwin extremely slow when McAffe Endpoint security is active

Jump to solution

I'm using Cygwin on my Win 10 laptop.
But some commands are incredible slow if McAffe Endpoint security v 10.5 is active.
E.g. starting a cygwin window (mintty -) will take about 15-18 secs.
executing  bash -l will take about 12 secs.
each execution of man command will take about 10 - 12 secs
When disabled all of the above take about 1 sec or less.
In addition during execution of above commands McAfee processes (mcshield.exe and mfeatp.exe) will consume almost 100% CPU).
This also has significant impact on up-time of my laptop when on battery.

1 Solution

Accepted Solutions
Reliable Contributor SWISS
Reliable Contributor
Report Inappropriate Content
Message 3 of 3

Re: cygwin extremely slow when McAffe Endpoint security is active

Jump to solution

Hello,

This has been resolved in ENS 10.6.1 DECEMBER UPDATE (HOTFIX). There was a memory leak with CYGWIN with Mcafee ENS 10.6.X before that release.

Regards

Mike/Switzerland

http://www.butsch.ch/post/MCAFEE-ENS-1061-DEZ-UPD-resolves-Memory-Leak-with-CYGWIN-(example-Wireshar...

 

2 Replies
Highlighted
Reliable Contributor bodysoda
Reliable Contributor
Report Inappropriate Content
Message 2 of 3

Re: cygwin extremely slow when McAffe Endpoint security is active

Jump to solution

Are you running the ENS 10.5.0 if so, upgrade to the 10.5.2 atleast. According to KB82450, issues resolved in 10.5.6 June update and earlier section. 

Endpoint Security 10.x Known Issues

Issue: Code compiling programs like Cygwin can take longer to build projects with out-of-box configurations of ENS 10.5.0.

Resolution: The issue is resolved in ENS 10.5.2.

 
In case above information was useful or answered your question, please select "Accept as Solution" in my reply, or give a Kudo. Thanks!
Reliable Contributor SWISS
Reliable Contributor
Report Inappropriate Content
Message 3 of 3

Re: cygwin extremely slow when McAffe Endpoint security is active

Jump to solution

Hello,

This has been resolved in ENS 10.6.1 DECEMBER UPDATE (HOTFIX). There was a memory leak with CYGWIN with Mcafee ENS 10.6.X before that release.

Regards

Mike/Switzerland

http://www.butsch.ch/post/MCAFEE-ENS-1061-DEZ-UPD-resolves-Memory-Leak-with-CYGWIN-(example-Wireshar...

 

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community