cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

VSE not removed when ENS installed

Jump to solution
We have just updated to ePO 5.10 and I am migrating servers onto the new environment and updating from VSE8.8 to ENS 10.6.1 and TP once migrated. I am having an issue with some of the servers, where the VSE install is not being removed and TP does not get installed. Can I remotely remove VSE from the console? or is there another way of getting it removed? If I connect to the server and manually uninstall VSE, then TP goes on without an issue.
1 Solution

Accepted Solutions
Thussain
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 5

Re: VSE not removed when ENS installed

Jump to solution

Thank you for posting your query

You can create a product deployment task in EPO with the option to remove selected and assign it to the client machine to uninstall VSE

The Other option would be to manually log in to the machine using RDP session and then run the Endpoint product Removal tool. You can download the EPR (Endpoint Product Removal tool) from the Mcafee download webiste. 

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

View solution in original post

4 Replies
Thussain
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 5

Re: VSE not removed when ENS installed

Jump to solution

Thank you for posting your query

You can create a product deployment task in EPO with the option to remove selected and assign it to the client machine to uninstall VSE

The Other option would be to manually log in to the machine using RDP session and then run the Endpoint product Removal tool. You can download the EPR (Endpoint Product Removal tool) from the Mcafee download webiste. 

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

View solution in original post

Re: VSE not removed when ENS installed

Jump to solution

Thanks for that, worked perfectly 🙂

AdithyanT
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 5

Re: VSE not removed when ENS installed

Jump to solution

Hi @nicksullivan 

Kudos to you for letting us know and helping other community members with similar questions by marking a solution!

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
AdithyanT
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 5

Re: VSE not removed when ENS installed

Jump to solution

Hi @nicksullivan 

First of all, a rally good post.You have the solution at hand (removal of VSE) and you are looking at various ways of implementing it, if I am not wrong.

Here are the list of options I can think of. I am sure there a few more than can be explored too and @Thussain has already shared a couple of them too above which are also included here.

*Please note, all these steps require an ENS deployment task to be run in order to get ENS installed into the machine. All removal is required to perform a reboot, although ENS may get installed successfully without a reboot as well. just sharing best practice :).

  1. Confirm if VSE installed on all these machines are of the same version. If Yes, get the uninstall string from Registry (Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall) and you can create a batch file to be run as logon script to get rid of VSE.
  2. If the version of VSE is checked into the repository(if not present, you can always check that in using Software manager/catalog) and deploy an uninstall task from the ePO. This is exactly the same as doing a deployment task of VSE, however in the drop down box of the task where it would say "install" you would select "remove" as the option. 
  3. You can use the EPR tool by downloading it from the product downloads site using your Grant#. It is found under utilities and connectors. More info on obtaining the tool can be found here. Information on it's usage can be found here.
  4. I am sure this is something that is not happening and is the very reason why you have created this post, still, You can straight away deploy ENS installation task that should uninstall VSE using the in built removal tool.

I hope the above options are helpful in getting the issue resolved. Good luck!

P.S: I would also be interested to understand how ENS is unable to install VSE installed on the machine and probably dig into the logs and identify root cause. Deploying newer version of ENS can always help if you are already not doing so!

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community