cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with ENS on a specific machine

Hi!

I'm facing a weird problem with ENS on my work machine.

I installed the first July update and when I checked that it had problems, I didn't release it to the rest of the company.

Now that the second July update is out (10.6.1.1340.1), I've installed it on other machines. It is working well. But my machine continues to have problems...

It started by Windows 10 1903 (full updated) saying that McAfee had stopped working and then changing to Windows Defender. So I uninstalled McAfee ENS and tried to reinstall it again.

Same problem.

So I used the ENS Removal Tool (19.5.0.17) to removed all products from McAfee from my PC.

Finished, restarted the PC, and installed first the Agent from ePO and then ENS, from ePO too.

Then ePO stayed for one week without not being able to get information from my machine and not receiving the policies correctly and Windows Defender is the main antivirus for my PC since then.

I also tried to install using the standalone installer.

Here are some screenshots of what I have:

About ENS.jpg

Control Panel.jpg

ePO.jpg

Windows Defender.jpg

Since there is no way to stop ENS services like we did with VirusScan, how can I fix this and make sure that Windows Defender will not be the main AV solution on my machine?

Att,
Vandrey Trindade
6 Replies

Re: Problem with ENS on a specific machine

Update:

I have stopped Windows Defender and so I was able to start ENS again...

ENS.jpg

Will restart my machine to check if Windows Defender won't get back anymore...

Att,
Vandrey Trindade

Re: Problem with ENS on a specific machine

Yup... Once again, after rebooting the PC, Windows Defender took control again...

Att,
Vandrey Trindade

Re: Problem with ENS on a specific machine

Hello

windows Defender is being suppressed during ENS installation. Unfortunately your GPO settings has higher priority then the ENS has. So in case that you will enable the defender after ENS installation, then ENS isnt able to stop it itself.

https://www.prajwaldesai.com/how-to-turn-off-windows-defender-using-group-policy/

Should be set to not configured. Then the ENS installation will be able to disable it

Re: Problem with ENS on a specific machine

Sorry, but who said that there is any GPO configured in my environment?

Att,
Vandrey Trindade

Re: Problem with ENS on a specific machine

I am not saying that GPO is defined in your environment on domain level, but could be enabled locally on your machine. As i have mentioned, the service is being disabled during the ENS installation. Logical is that something is enabling it after re-log.

Re: Problem with ENS on a specific machine

There is no GPO configured locally on my machine.

Att,
Vandrey Trindade
More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community