cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 1 of 12

Problem with ENS on a specific machine

Jump to solution

Hi!

I'm facing a weird problem with ENS on my work machine.

I installed the first July update and when I checked that it had problems, I didn't release it to the rest of the company.

Now that the second July update is out (10.6.1.1340.1), I've installed it on other machines. It is working well. But my machine continues to have problems...

It started by Windows 10 1903 (full updated) saying that McAfee had stopped working and then changing to Windows Defender. So I uninstalled McAfee ENS and tried to reinstall it again.

Same problem.

So I used the ENS Removal Tool (19.5.0.17) to removed all products from McAfee from my PC.

Finished, restarted the PC, and installed first the Agent from ePO and then ENS, from ePO too.

Then ePO stayed for one week without not being able to get information from my machine and not receiving the policies correctly and Windows Defender is the main antivirus for my PC since then.

I also tried to install using the standalone installer.

Here are some screenshots of what I have:

About ENS.jpg

Control Panel.jpg

ePO.jpg

Windows Defender.jpg

Since there is no way to stop ENS services like we did with VirusScan, how can I fix this and make sure that Windows Defender will not be the main AV solution on my machine?

Att,
Vandrey Trindade
1 Solution

Accepted Solutions
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 12

Re: Problem with ENS on a specific machine

Jump to solution

It's being fixed as part of the next release. This is targeted for October.

Was my reply helpful?
If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?

View solution in original post

11 Replies
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 12

Re: Problem with ENS on a specific machine

Jump to solution

Update:

I have stopped Windows Defender and so I was able to start ENS again...

ENS.jpg

Will restart my machine to check if Windows Defender won't get back anymore...

Att,
Vandrey Trindade
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 3 of 12

Re: Problem with ENS on a specific machine

Jump to solution

Yup... Once again, after rebooting the PC, Windows Defender took control again...

Att,
Vandrey Trindade
Highlighted

Re: Problem with ENS on a specific machine

Jump to solution

Hello

windows Defender is being suppressed during ENS installation. Unfortunately your GPO settings has higher priority then the ENS has. So in case that you will enable the defender after ENS installation, then ENS isnt able to stop it itself.

https://www.prajwaldesai.com/how-to-turn-off-windows-defender-using-group-policy/

Should be set to not configured. Then the ENS installation will be able to disable it

Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 5 of 12

Re: Problem with ENS on a specific machine

Jump to solution

Sorry, but who said that there is any GPO configured in my environment?

Att,
Vandrey Trindade
Highlighted

Re: Problem with ENS on a specific machine

Jump to solution

I am not saying that GPO is defined in your environment on domain level, but could be enabled locally on your machine. As i have mentioned, the service is being disabled during the ENS installation. Logical is that something is enabling it after re-log.

Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 7 of 12

Re: Problem with ENS on a specific machine

Jump to solution

There is no GPO configured locally on my machine.

Att,
Vandrey Trindade
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 8 of 12

Re: Problem with ENS on a specific machine

Jump to solution

I read this article:

https://kc.mcafee.com/agent/index?page=content&id=KB91830

I've subscribed to it now.

But, after 1 month, McAfee wasn't supposed to already fix it? This is not a free product.

Att,
Vandrey Trindade
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 12

Re: Problem with ENS on a specific machine

Jump to solution

It's being fixed as part of the next release. This is targeted for October.

Was my reply helpful?
If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?

View solution in original post

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 10 of 12

Re: Problem with ENS on a specific machine

Jump to solution

Hello @vandreytrindade ,

Thank you for your query.

As per your issue and the KB mentioned in the query the issue seems to be with "Windows Security Center reports that ENS is disabled. Windows Security Center can prompt to enable Windows Defender."

Please be advised that this issue is resolved in ENS 10.6.1 May Update.

See the related article for more information.

https://kc.mcafee.com/corporate/index?page=content&id=KB82450

https://kc.mcafee.com/corporate/index?page=content&id=KB91428

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Amit N
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community