cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

McAfee ENS Product Deployment Failing

Hi,

I've upgraded most machines to the most recent version of ENS, however there is one system that had the Platform version upgraded, but not the other products (Threat Prevention, Adaptive Threat Prevention, and Firewall).

When I try and run a client task on the system to upgrade just a single product, I get the following error (this one was for Threat Prevention but they all give the same error):

Details: Product "ENDP_AM_1070" uninstallation failed, reason "Unknown error"..

 

I do not have access to retrieve logs from the system at the moment. I was wondering if anyone has experience this before and can give me some directions on how to proceed.

Thanks!

 

-OB

3 Replies
AjaySundar
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 4

Re: McAfee ENS Product Deployment Failing

Hi @User32655584,

Good day to you!

From the error provided I guess you are using the "Run client task now" option to perform the upgrade/install? We would recommend you to schedule the installation task rather than using the above option as it is bound to throw errors if there are other tasks with higher priority keeps running behind the scene.

Please try to schedule the deployment task and let us know if this resolves the issue, if not we will have to take a look at the logs to understand the issue further and suggest the action plan accordingly.

Regards,

AJ

Re: McAfee ENS Product Deployment Failing

Thank you for your response Ajay.

I tried a run client task now and a scheduled task today on another system that got all products installed except for ENS (both tasks failed).

I checked the McAfee logs from the system and the last time they were modified was 7 days ago.

The system is online and communicating with ePO, but the tasks are not successful.

Which log would give more info as to why the tasks are failing?

AjaySundar
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 4

Re: McAfee ENS Product Deployment Failing

Hi @User32655584,

Please search the masvc.log for the task that you have pushed from the ePo.

If you are using the latest MA version you should also see McScript_Deploy.log getting generated if the installation task has reached and becomes active on the given client machine.

The McAfee Agent logs can be found under the path below:

C:\ProgramData\McAfee\Agent\logs

If you need some assistance, please upload the masvc.log, McScript.log, and McScript_deploy.log along with the task name here to check further.

Regards,

AJ

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community