cancel
Showing results for 
Search instead for 
Did you mean: 
Reliable Contributor bodysoda
Reliable Contributor
Report Inappropriate Content
Message 1 of 8

McAfee ENS 10.6.1 February Update - McAfee Temporary Installer Service

Jump to solution

Looks like ENS 10.6.1 Feb update relased last night and I deployed to some group of servers. I found the hotfix installer doesnt remove the service "McAfee Temporary Installer Service"  after it finishes. 

Service execution path is "C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\HotFix\190212\0000\mfehidin.exe" -service mfemms

I can't change the startup type "Automatic" to manaul as I get "Access Denied".   

Affected servers has been rebooted as well. "McAfee Temporary Installer Service" exist even after the reboot. 

Our monitoring system is going crazy as the automatic service doesnt start. 

How do I remediate (remove) "McAfee Temporary Installer Service"? 

mcafeetemporaryservice.jpg

McafeeAccessDenied.jpg

mcafee_program_Path.jpg

In case above information was useful or answered your question, please select "Accept as Solution" in my reply, or give a Kudo. Thanks!
1 Solution

Accepted Solutions
McAfee Employee jess_arman
McAfee Employee
Report Inappropriate Content
Message 2 of 8

Re: McAfee ENS 10.6.1 February Update - McAfee Temporary Installer Service

Jump to solution

@bodysoda Engineering is currently investigating potential causes for this behavior to determine if it is consistently reproducible or if there are only certain factors which could cause this to occur, as it has been seen by a customer with the 10.5.5 January Update package.

If you would like to contribute to these investigation efforts, then you are welcome and encouraged to open an SR and work with Support to gather the necessary data to submit a child defect to BZ1266443.

Please note that the presence of this Temporary Installer Service should not alter the behavior of ENS and is not likely to cause any issues.

 

Was my reply helpful?

If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?

View solution in original post

7 Replies
McAfee Employee jess_arman
McAfee Employee
Report Inappropriate Content
Message 2 of 8

Re: McAfee ENS 10.6.1 February Update - McAfee Temporary Installer Service

Jump to solution

@bodysoda Engineering is currently investigating potential causes for this behavior to determine if it is consistently reproducible or if there are only certain factors which could cause this to occur, as it has been seen by a customer with the 10.5.5 January Update package.

If you would like to contribute to these investigation efforts, then you are welcome and encouraged to open an SR and work with Support to gather the necessary data to submit a child defect to BZ1266443.

Please note that the presence of this Temporary Installer Service should not alter the behavior of ENS and is not likely to cause any issues.

 

Was my reply helpful?

If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?

View solution in original post

Re: McAfee ENS 10.6.1 February Update - McAfee Temporary Installer Service

Jump to solution

This also happens with the VSE 8.8 hotfix released the other day.

McAfee Employee akatt
McAfee Employee
Report Inappropriate Content
Message 4 of 8

Re: McAfee ENS 10.6.1 February Update - McAfee Temporary Installer Service

Jump to solution

@bodysoda  @philrandal 

This is definitely an interesting report/issue.  When it was reported on this post yesterday, we had several technicians attempt to reproduce the behavior, and they could not.  Do either of you mind opening a service request with support?  The preference would be to properly track this reported behavior, and determine a good focus for continued troubleshooting.

A temporary service remaining after install could lead to a volume increase in customer concerns/support calls.  If we can go ahead and dig into the behavior, it would be beneficial for everyone.

Please don't hesitate to continue to provide any additional context regarding the issue, as all informaton at this time is beneficial.


Was my reply helpful?

If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?



Reliable Contributor bodysoda
Reliable Contributor
Report Inappropriate Content
Message 5 of 8

Re: McAfee ENS 10.6.1 February Update - McAfee Temporary Installer Service

Jump to solution
Yes, I've logged a support ticket 4-19726971483 and provided MER logs to the support.
To reproduce the issue, I'm sourcing test machines as I've run out of test machine as all of them have current ENS installed.
In case above information was useful or answered your question, please select "Accept as Solution" in my reply, or give a Kudo. Thanks!
Highlighted
McAfee Employee akatt
McAfee Employee
Report Inappropriate Content
Message 6 of 8

Re: McAfee ENS 10.6.1 February Update - McAfee Temporary Installer Service

Jump to solution

@bodysoda 

Good deal.  For what it is worth, we appreciate that partnership and willingness to investigate.  The more we "rip/reboot/reinstall," the less we can properly address.  Curious to see the result from this one.


Reliable Contributor bodysoda
Reliable Contributor
Report Inappropriate Content
Message 7 of 8

Re: McAfee ENS 10.6.1 February Update - McAfee Temporary Installer Service

Jump to solution
I can manually reboot & delete "McAfee Temporary Installer Service " using command "sc Delete mfehidin_svc ".


Product: McAfee Endpoint Security Platform - Update 'McAfee Endpoint Security Common' installed successfully.

Log Name: Application
Source: MsiInstaller
Date: 13/02/2019 5:41:11 p.m.
Event ID: 1022
Task Category: None
Level: Information
Keywords: Classic
User: SYSTEM
Computer: XXXXXXXXX
Description:
Product: McAfee Endpoint Security Platform - Update 'McAfee Endpoint Security Common' installed successfully.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="MsiInstaller" />
<EventID Qualifiers="0">1022</EventID>
<Level>4</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2019-02-13T04:41:11.000000000Z" />
<EventRecordID>728992</EventRecordID>
<Channel>Application</Channel>
<Computer>XXXXXXXX</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData>
<Data>McAfee Endpoint Security Platform</Data>
<Data>McAfee Endpoint Security Common</Data>
<Data>(NULL)</Data>
<Data>(NULL)</Data>
<Data>(NULL)</Data>
<Data>(NULL)</Data>
<Data>
</Data>
<Binary>XXXXXXXXXXXXXXXXXXXXXXX</Binary>
</EventData>
</Event>


Product: McAfee Endpoint Security Platform. Restart required. The installation or update for the product required a restart for all changes to take effect. The restart was deferred to a later time.

Log Name: Application
Source: MsiInstaller
Date: 13/02/2019 5:41:11 p.m.
Event ID: 1029
Task Category: None
Level: Information
Keywords: Classic
User: SYSTEM
Computer: XXXXXXXX
Description:
Product: McAfee Endpoint Security Platform. Restart required. The installation or update for the product required a restart for all changes to take effect. The restart was deferred to a later time.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="MsiInstaller" />
<EventID Qualifiers="0">1029</EventID>
<Level>4</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2019-02-13T04:41:11.000000000Z" />
<EventRecordID>728997</EventRecordID>
<Channel>Application</Channel>
<Computer>XXXXXXXXXXXX</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData>
<Data>McAfee Endpoint Security Platform</Data>
<Data>(NULL)</Data>
<Data>(NULL)</Data>
<Data>(NULL)</Data>
<Data>(NULL)</Data>
<Data>(NULL)</Data>
<Data>
</Data>
<Binary>XXXXXXXXXXXXXXXXX</Binary>
</EventData>
</Event>
In case above information was useful or answered your question, please select "Accept as Solution" in my reply, or give a Kudo. Thanks!

Re: McAfee ENS 10.6.1 February Update - McAfee Temporary Installer Service

Jump to solution

A colleague has raised SR 4-19742593991 for the issue in VSE 8.8 HF 1262936.

Cheers,

Phil

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community