cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7
Report Inappropriate Content
Message 1 of 10

MMC consoles break after ENS install

After installing ENS 10.6 (upgrade from VirusScan 8.8) we see this message when opening a MMC console eg Print Management, SCOM Console "An attempt was made to reference a token that does not exist" We have seen this on the following OS's Server 2008 R2 Server 2012 R2 Server 2016 This was not occuring before the upgrade to ENS
9 Replies
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 10

Re: MMC consoles break after ENS install

Have you tried to disable ENS and see if the issue goes away? Have you tried to uninstall ens to see if issue is reproducible?

 

Sometimes you try to open "Microsoft Management Console (MMC)" and you receive "An attempt was made to reference a token that does not exist" error. This error may be caused by corrupt files

Here is your Solution:

Open a Command Prompt (CMD) in ELEVATED MODE (run as administrator) and navigate to %WINDIR%\System32 and re-register the required DLL files using the following command:

For /F %s in ('dir /b *.dll') do regsvr32 /s %s

McAfee Support

Benjamin Ellis

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Level 7
Report Inappropriate Content
Message 3 of 10

Re: MMC consoles break after ENS install

Thanks, I found the solution to re register the dlls' which does work.

Do we know why/how the ENS install breaks this in the first place? A fix to stop this occuring during the ENS install would be better than running the fix to resolve the issue


The issue is reproducable in that if we install ENS on another server we often (not always) get the issue.


In my limited amount of testing the ENS install only appears to cause the issue on the first install.

Level 7
Report Inappropriate Content
Message 4 of 10

Re: MMC consoles break after ENS install

Thanks, I found the solution to re register the dlls' which does work.

Do we know why/how the ENS install breaks this in the first place? A fix to stop this occuring during the ENS install would be better than running the fix to resolve the issue


The issue is reproducable in that if we install ENS on another server we often (not always) get the issue.


In my limited amount of testing the ENS install only appears to cause the issue on the first install.

Level 10
Report Inappropriate Content
Message 5 of 10

Re: MMC consoles break after ENS install

When will a fix for this be sent out?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 10

Re: MMC consoles break after ENS install

-confirmed related to EUA,  fixed build is 2.3.0.23
-customer confirmed issue not present when using newer EUA build

Level 10
Report Inappropriate Content
Message 7 of 10

Re: MMC consoles break after ENS install

Currently in my ePO, I have Endpoint Upgrade Assistant 2.0.0.56, and the next available update to check-in is 2.1.0.38. Where would I get this latest version?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 10

Re: MMC consoles break after ENS install

@nthnu You can view and download/check-in the latest available versions of most products within your Software Manager on your ePO. However, you can also visit your Product Downloads page and log in with your Grant number in order to view all available products and versions that you're licensed for. You would simply search "Endpoint Upgrade Assistant" or select the category "utilities & connectors" to find it. 
The latest version of EUA available is actually 2.3: PD27992.

 

Was my reply helpful?

If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?

Level 10
Report Inappropriate Content
Message 9 of 10

Re: MMC consoles break after ENS install

Ok, it seems our avenue for obtaining software from that link isn't possible. We have the grant number but aren't given the email address that goes with it. Also, is 2.3 for ENS 10.6 or can it also be used with 10.5.4?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 10 of 10

Re: MMC consoles break after ENS install

@nthnu The Grant Number is not tied to a single email within your organization. You should not have issues logging in with your email as long as you have the Grant Number.
You can use EUA with many versions of ENS, including 10.6 and 10.5.4. Its designed for you to be able to customize it to your needs.

 

Was my reply helpful?

If this information was helpful in any way, or answered your question, will you please select "Accept as Solution" in my reply, or give kudos as appropriate, so together we can help other members?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community