cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Endpoint won't install on Server 2016

Jump to solution
When I push the agent from EPO 10 it deploys ok, However the Endpoint TP keeps failing with below message Sent Run Now task "Endpoint Security Deployment Task (Default)" to "PHIERI-S7063" Run now task Endpoint Security Deployment Task (Default) received. Run now task started. Run now task Endpoint Security Deployment Task (Default) failed.
Details: Product "ENDP_GS_1060" installation failed, reason "Point Product Custom Error".
Product "ENDP_AM_1060" installation failed, reason "Unknown error".
Product "ENDP_GS_1060" installation failed, reason "Point Product Custom Error".
Product "ENDP_FW_1060" installation failed, reason "Unknown error".
Product "ENDP_GS_1060" installation failed, reason "Point Product Custom Error".
Product "ENDP_WP_1060" installation failed, reason "Unknown error".. Task Completed Any ideas why? Thanks
1 Solution

Accepted Solutions
McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 15 of 15

Re: Endpoint won't install on Server 2016

Jump to solution

Hi @User97718302,

Apologies for the delay in response. Thanks for your reply. I think we have referred a different article here. The one @mmuthuga meant to send was this:

https://kc.mcafee.com/corporate/index?page=content&id=KB87096

There is a misdirection in the links due to which the KB when clicked redirected to a different one. Apologies for the inconvenience.

Please click on the link I have given here and that is expected to resolve your issue. Please keep us posted on how this goes!

 

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
14 Replies
McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 2 of 15

Re: Endpoint won't install on Server 2016

Jump to solution

Hi @User97718302,

Thank you for the post. From what I see, The installation failure should be investigated by finding out which component failed first. Can you look into the endpoint Bootstrapper log (McAfee_Endpoint_BootStrapper_<%timestamp%>.log) found under C:\Windows\Temp\McAfeeLogs and check if you get any failures for specific components while installing?

Are you trying a fresh installation or an upgrade?

May I know what version you are trying too install on the machine?

Depending on the point of failure and logs we look into, this is going to take some time to investigate and find the cause and possibly achieve a solution. If you prefer on call or remote session, I would like to propose contacting Technical Support directly by creating a Service Request.

I sincerely hope this helps!

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T

Re: Endpoint won't install on Server 2016

Jump to solution

Thanks for the quick reply.Is the boot strapper log on the EPO serveror the destination client?  This is to deploy to new servers running 2016. The Mcafee Agent is version 5.6.2.209 and the endpoint version that's failing is 10.6.1.1724.

 

Regards

 

Rob

McAfee Employee Thussain
McAfee Employee
Report Inappropriate Content
Message 4 of 15

Re: Endpoint won't install on Server 2016

Jump to solution

The Boot strapper logs in found on the client machine

you should see it in C:\Windows\Temp\mcafeelogs

or in the C:\Users\username\AppData\Local\Temp

The bootstrapper logs help us understand what component is causing the failure. This starting point for troubleshooting of installation failures

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 5 of 15

Re: Endpoint won't install on Server 2016

Jump to solution

Hi @User97718302,

Thank you for your response. These log files are to be checked on the endpoint side. As we can see the task is being run, however, the installation is failing due to point product error (in this case, endpoint Security and it's components).

Since it is a new deployment, I am fairly confident we can resolve it once we get our hands on the required log files.

Please sanitize the logs of any sensitive information like IP Address or hostnames/FQDNs in case you are uploading them here for our review.

You can alternately look for lines with failures in the logs and share just them without disclosing and sensitive information here. I will be glad to be of help with review of logs.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T

Re: Endpoint won't install on Server 2016

Jump to solution

This is the last bootstrapper log from the client

 

07/11/2019 17:08:04.928 [3220] [BootstrapperMain] Common:Product version :10.6.1
07/11/2019 17:08:04.928 [3220] [BootstrapperMain] Common:Build number - 1724 , Package number - 1
07/11/2019 17:08:04.928 [3220] [BootstrapperMain] Package MA version 5.5.1.342 Minimum MA Build supported is 5.0.2.233
07/11/2019 17:08:04.928 [3220] [BootstrapperMain] Could not get any related ENS product to obtain custom path.
07/11/2019 17:08:04.928 [3220] [BootstrapperMain] Unable to read RunAppInfo.xml. No bundled app installation will be performed.
07/11/2019 17:08:04.944 [3220] [BootstrapperMain] Commandline: /qn /norestart /managed
07/11/2019 17:08:04.944 [3220] [BootstrapperMain] SetupCC CCommonBladeBootstrapper::HandleCommandLine()
07/11/2019 17:08:04.944 [3220] [BootstrapperMain] Could not get any related ENS product to obtain custom path.
07/11/2019 17:08:04.944 [3220] [BootstrapperMain] Commandline: /qn /norestart /managed
07/11/2019 17:08:04.944 [3220] [BootstrapperMain] Free Space in Drive 'C:': 131404392 Kb
07/11/2019 17:08:04.944 [3220] [BootstrapperMain] System already has MSXML 6 installed
07/11/2019 17:08:04.959 [3220] [BootstrapperMain] Package MA version 5.5.1.342 Minimum MA Build supported is 5.0.2.233
07/11/2019 17:08:04.959 [3220] [BootstrapperMain] Managed mode. Skipping MA Install
07/11/2019 17:08:05.100 [3220] [BootstrapperMain] Running mfeCompatCheck exe : C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\MfeSysPrep.exe
07/11/2019 17:08:05.116 [3220] [BootstrapperMain] RunCommandLine: C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\MfeSysPrep.exe
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] RunCommandLine: Process return code : 0
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] mfeCompatCheck exe returned success
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] Check if installed common is 10.5.3, need to install a HF for 10.5.3 befores upgrade
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] Registry key SOFTWARE\McAfee\Endpoint\Common not seen : 2
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] Cannot find VSCore version
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] vscore will be installed after legacy products removal
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] Common:Build number - 1724 , Package number - 1
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] Patch version of ESP to Check is 0
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] No patch check required
07/11/2019 17:08:08.881 [3220] [BootstrapperMain] RunCommandLine: C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\\mfeepmpk_utility.exe -r -f -log "C:\Windows\TEMP\\McAfeeLogs\McAfee_Update_Exp_Driver_07112019170808881.log"
07/11/2019 17:08:08.897 [3220] [BootstrapperMain] RunCommandLine: Process return code : 0
07/11/2019 17:08:08.897 [3220] [BootstrapperMain] Utility to update ENS exp driver determined no driver replacement required
07/11/2019 17:08:08.897 [3220] [BootstrapperMain] Cannot find VSCore location so failed to update certificate
07/11/2019 17:08:08.897 [3220] [BootstrapperMain] Checking if HIP content requires update...
07/11/2019 17:08:08.897 [3220] [BootstrapperMain] HIP content key not opened
07/11/2019 17:08:08.897 [3220] [BootstrapperMain] HIP content update not needed
07/11/2019 17:08:08.897 [3220] [BootstrapperMain] Detecting and uninstalling competitor's products.
07/11/2019 17:08:08.897 [3220] [BootstrapperMain] RunCommandLine: C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\\uninst.exe -R uninst.ini -S -L -A -G 0900
07/11/2019 17:08:10.600 [3220] [BootstrapperMain] RunCommandLine: Process return code : 1
07/11/2019 17:08:10.600 [3220] [BootstrapperMain] RunCommandLine: C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\\uninstX64.exe -R uninst.ini -S -L -A -G 0900
07/11/2019 17:08:12.725 [3220] [BootstrapperMain] RunCommandLine: Process return code : 1
07/11/2019 17:08:12.725 [3220] [BootstrapperMain] ForceReboot is off.
07/11/2019 17:08:12.725 [3220] [BootstrapperMain] Searching for MVISION Endpoint...
07/11/2019 17:08:12.725 [3220] [BootstrapperMain] Build to Build upgrade has not been attempted on the system. Hence proceeding with preserve settings.
07/11/2019 17:08:12.741 [3220] [BootstrapperMain] Solidcore not found. Installation proceeds further.
07/11/2019 17:08:12.757 [3220] [BootstrapperMain] Source Product McAfee TPSConnector 10.0 not Installed
07/11/2019 17:08:12.757 [3220] [BootstrapperMain] Source Product Threat Intelligence Exchange Module for Virus Scan Enterprise 1.0 not Installed
07/11/2019 17:08:12.757 [3220] [BootstrapperMain] Source Product McAfee VirusScan Enterprise 8.7 not Installed
07/11/2019 17:08:12.757 [3220] [BootstrapperMain] Source Product McAfee VirusScan Enterprise 8.8 not Installed
07/11/2019 17:08:12.757 [3220] [BootstrapperMain] Source Product McAfee Site Advisor Enterprise 3.0 not Installed
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] Source Product McAfee Site Advisor Enterprise 3.5 not Installed
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] Source Product HIPS 8.0 X86 not Installed
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] Source Product HIPS 8.0 X64 not Installed
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] Cleaning up temp migration path : C:\Windows\Temp\McafeeTmpMigration
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] Cannot retrieve ESP version
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] Searching for MVISION Endpoint...
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] Checking for vscore cab file
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\\vscore_all.cab
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] Found Install ALL cab file
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] Copied from C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\\mfehidin64.exe to C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\\mfehidin.exe
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] "C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\\mfehidin.exe" -installcab:"vscore_all.cab" -guid:{EA334ECD-7513-486B-A265-0C698FACBB06} -log:"C:\Windows\TEMP\\McAfeeLogs\McAfee_Common_VSCore_Install_All_07112019170812772.log" -etl:"C:\Windows\TEMP\\McAfeeLogs\McAfee_Common_VSCore_Install_All_07112019170812772.etl"
07/11/2019 17:08:12.772 [3220] [BootstrapperMain] RunCommandLine: "C:\ProgramData\McAfee\Agent\Current\ENDP_GS_1060\Install\0000\\mfehidin.exe" -installcab:"vscore_all.cab" -guid:{EA334ECD-7513-486B-A265-0C698FACBB06} -log:"C:\Windows\TEMP\\McAfeeLogs\McAfee_Common_VSCore_Install_All_07112019170812772.log" -etl:"C:\Windows\TEMP\\McAfeeLogs\McAfee_Common_VSCore_Install_All_07112019170812772.etl"
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] RunCommandLine: Process return code : 4294967295
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] VSCore Installation Return value : 4294967295
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] VSCore Error 0x20003041 Message: Error while stopping McAfee service.

07/11/2019 17:08:30.273 [3220] [BootstrapperMain] VSCore Installation failed!!
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] CheckIfPreviousProductRemoved: Start
SUBKESY(SOFTWARE\McAfeeEndpointSecurity_ModuleRemovalTracker) KEYNAME(MajorUpgradeProductsCount)
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] bOldrPrdtUninstallState(0)
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] Common failed during install or Upgrade!!!
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] Check if any ENS is left on the system
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] Upgrade code {74B710CF-552E-47D1-8CBF-D0AC2DA67B06} not detected on this system
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] Upgrade code {858BFBEC-CE4F-4C5A-AD02-F88B7A3F670C} not detected on this system
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] Upgrade code {B2ABA365-ABA2-4E4F-8FE3-7C216A033359} not detected on this system
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] Upgrade code {A1460C1B-0603-4AB7-84F0-37F06AB91F6D} not detected on this system
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] Upgrade code {E68F630E-837B-4CAF-83F8-3285701D451C} not detected on this system
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] No ENS is left on the system. We need to dereference 15.7+ vscore now
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] Extracting vscore uninstall helper
07/11/2019 17:08:30.273 [3220] [BootstrapperMain] C:\Windows\TEMP\MfeVSCoreUninst.exe
07/11/2019 17:08:30.430 [3220] [BootstrapperMain] The command for helper util : "C:\Windows\TEMP\MfeVSCoreUninst.exe" /PPGUID={EA334ECD-7513-486B-A265-0C698FACBB06}
07/11/2019 17:08:30.430 [3220] [BootstrapperMain] RunCommandLine: "C:\Windows\TEMP\MfeVSCoreUninst.exe" /PPGUID={EA334ECD-7513-486B-A265-0C698FACBB06}
07/11/2019 17:08:30.461 [3220] [BootstrapperMain] RunCommandLine: Process return code : 4294967295
07/11/2019 17:08:30.461 [3220] [BootstrapperMain] !> Error - Could not run command to uninstall vscore helper util: -1
07/11/2019 17:08:30.461 [3220] [BootstrapperMain] VSCore uninstall helper failed. Returning!!
07/11/2019 17:08:30.461 [3220] [BootstrapperMain] Extracting MfeEpAac_mfeprotect.exe : C:\Windows\TEMP\MfeEpAac_mfeprotect.exe
07/11/2019 17:08:30.539 [3220] [BootstrapperMain] Extraction successful
07/11/2019 17:08:30.539 [3220] [BootstrapperMain] This is a 64 bit system
07/11/2019 17:08:30.539 [3220] [BootstrapperMain] "C:\Windows\TEMP\MfeEpAac_mfeprotect.exe" -add -rootlocation "C:\Program Files\McAfee\Endpoint Security" -rootlocation "C:\Program Files (x86)\McAfee\Endpoint Security" -folder "C:\ProgramData\McAfee\Endpoint Security"
07/11/2019 17:08:30.539 [3220] [BootstrapperMain] RunCommandLine: "C:\Windows\TEMP\MfeEpAac_mfeprotect.exe" -add -rootlocation "C:\Program Files\McAfee\Endpoint Security" -rootlocation "C:\Program Files (x86)\McAfee\Endpoint Security" -folder "C:\ProgramData\McAfee\Endpoint Security"
07/11/2019 17:08:30.554 [3220] [BootstrapperMain] RunCommandLine: Process return code : 0
07/11/2019 17:08:30.554 [3220] [BootstrapperMain] Running application to gain installer exclusion succeeded.
07/11/2019 17:08:30.554 [3220] [BootstrapperMain] Checking for HIPS product with Product Code : {D2B9C003-A3CD-44A0-9DE5-52FE986C03E5}

 

If that explains anything? FYI I treied it on a second server and got the same thing. Version issue maybe?

 

 

McAfee Employee mmuthuga
McAfee Employee
Report Inappropriate Content
Message 7 of 15

Re: Endpoint won't install on Server 2016

Jump to solution

Bootstrapper log shows ENS Common install failed since VSCore install failed. VSCore is installed during ENS Common install. You can check  VSCore install log (McAfee_Common_VSCore_Install_All__<%timestamp%>.log) for some failure in KB's below to rule out usual suspects.

https://kc.mcafee.com/corporate/index?page=content&id=KB90124

https://kc.mcafee.com/corporate/index?page=content&id=KB87096

https://kc.mcafee.com/corporate/index?page=content&id=KB88817

 

Re: Endpoint won't install on Server 2016

Jump to solution

Thank you but there is no MaxNumFilters entry in the registry in the first place. This is for a Server 2016. 

Cheers

 

Rob

 

McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 9 of 15

Re: Endpoint won't install on Server 2016

Jump to solution

Hi @User97718302(Rob),

Thank you for your kind response. As mentioned earlier, we have found out the actual point of failure form the initial bootstrapper log. Now it is time to dig in further into the component failure. The component failing here is VSCore. Can you kindly please check the log file and if sanitized, can you also share it with us as mentioned by @mmuthuga above (McAfee_Common_VSCore_Install_All__<%timestamp%>.log)? The location remains the same.

Also, Thank you for your co operation here! Kudos to your efforts i helping us out with the logs.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 10 of 15

Re: Endpoint won't install on Server 2016

Jump to solution

Hi @User97718302,

Based on the log excerpt you have shared above, the precise log file we are looking for is this:

C:\Windows\TEMP\\McAfeeLogs\McAfee_Common_VSCore_Install_All_07112019170812772.log.

Please ensure the log file or the part of logs you share is sanitized of any sensitive information. I think I have been saying this too many times now, and You have been quite careful with the logs form what I see. So I will stop repeating this form now on! Thanks for understanding!

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community