Showing results for 
Search instead for 
Did you mean: 
Level 7

ENS Threat Prevention causing lag when opening windows applications


We have a system that is running ENS Threat Prevention, which is managed by ePO 5.3.  We are currently in the process of finalising a master image; however we are having performance issues when ENS Threat Prevention is installed.  What happens, is when the computer boots, when you try and open some windows base applications such as Device Manager, there will be a 5-10 second lag until the application opens.  Once the application has been opened at least once, then it opens quickly after that until the computer is restarted.  Sometimes some application will open fine, but other times they will not.  The lag only occurs with windows own built in applications, and has been noticed when opening things such as Device Manager, Task Sched, Remote Settings, Explorer and sometimes even just right clicking on the desktop.  The issues is definitely related to ENS TP, as when it is uninstalled the problem goes away.  Any help would be greatly appreciated.

Workstation: Dell M7510

Operating System: Windows 7 SP1 64-bit

Installed McAfee Products

Benchmark Editor Multi Platform Scan Engine:



ENS Security Platform 10.5.11216






0 Kudos
1 Reply
Level 10

Re: ENS Threat Prevention causing lag when opening windows applications

Your first port of call should be process monitor. Start capture, open an app, wait while the laggy issue occurs, then stop capture when the app appears.

Now you can comb through the app's history to see what it was doing.

To me this sounds like a timeout occured on one of the app's operations like check for internet connx or a file server connection. After the first use a cached response is used. Just a hunch anyway and not obvious why TP causes it.

Normally the answer is within the procmon capture.


0 Kudos