cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

ENS Installation fails

Jump to solution

Hello, all

My company has about 140 machines (Windows 7 and 10) failing to install ENS 10.6. The agent and DLP installs normally via SCCM, but ENS and ATP fails. Trying to install locally fail as well, freezing in about 10% of the installation process.

The problem seems to be on the installation of the dependencies, I often get this king of log:

[9880] [BootStrapperMain] Started installing Dependencies

[9880] [BootStrapperMain] Installing Common 1124.1

[9880] [BootStrapperMain] C:\ProgramData\McAfeeTmpInstall_Common\setupCC.exe /qn INSTALLDIR="C:\Program Files\McAfee\Endpoint Security" /ignore /norestart

[9880] [BootStrapperMain] Install failed return code : 4294967295

[9880] [BootStrapperMain] [ERROR]: Dependency Installation Failed. Dependency :Common

[9880] [BootStrapperMain] Modules Installation Failed

[9880] [BootStrapperMain] Exiting Installation.

Im kind of stuck, there are no apparently common reason between all those machines...there are different Windows versions, 1709, 1803, Windows 7, no other software that could be making this installation fails, I think...

Any ideas? Thanks in advance!

 

1 Solution

Accepted Solutions
McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 21 of 21

Re: ENS Installation fails

Jump to solution

Hi @Eduardo_Zeit,

Just adding my 2p here, There are some really good KBAs that should help you with investigation from dll injection perspective if you are interested in finding out more. Kindly please find below the KBAs:

 
These 2 KBAs talk about investigating installation failures. We have some more helps in investigating compatibility issues that comes up post installation as well. Please let us know if this helps!
Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
20 Replies
McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 2 of 21

Re: ENS Installation fails

Jump to solution

Hi @Eduardo_Zeit,

Thank you for your post here! Looking at the volume of the endpoints facing failure, I would recommend creating a Support Request with us.

Having said that, A quick thing I noticed here. We are looking at the endpoint Bootstrapper log here. Typically shows the start of the installation process and runs through till endpoint installation completes. Now here, it says dependency installation failed. Also it points out to what dependency it is failing. It is McAfee Endpoint Security Common also known as Endpoint Security Platform.

One more thing to note here: ENS 10.6.1 December Post is the package you are using based on the common version here: 1124.

I would recommend using a newer version atleast for the Windows 10 machines since starting from Windows 10 1903, as the December Package you are running is not compatible.

We can investigate more from the Common install log, however, I would recommend going for a support ticket on this. Do not hesitate to refer my name and if our work hours match, I can pick this one and work for you!

I sincerely hope this helps!

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
McAfee Employee Thussain
McAfee Employee
Report Inappropriate Content
Message 3 of 21

Re: ENS Installation fails

Jump to solution

Thank you for posting your query

Please let me know what is the version of ENS you are trying to install. 

Could you share the VSCore.log file from c:\windows\temp folder

you may also take a look at KBA below

https://kc.mcafee.com/corporate/index?page=content&id=KB90124

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Re: ENS Installation fails

Jump to solution

Hello, thanks for the replay, but there are no VSCore.log on that machine. Is that normal?

 

I am talking internally here to see if we can open a ticket...thanks 

 

McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 5 of 21

Re: ENS Installation fails

Jump to solution

Hi @Eduardo_Zeit,

Thank you for your response. I would recommend looking for 4 logs files here.

  • McAfee_Common_Install_xxxxx.log
  • McAfee_Common_VSCore_Install_All_xxxxx.log
  • McAfee_Common_CustomAction_Install_xxxxx.log
  • McAfee_Common_Bootstrapper_xxxxx.log - should point out which of these above 3 logs need to be looked into as it would point out at which stage the common component installation failed.

Log location:

C:\Windows\Temp\McAfeeLogs\ - if the deployment was done from ePO.

*Note: If you are uploading any logs to this public forum, please ensure the data is sanitized and does not contain any sensitive information like IP addresses.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T

Re: ENS Installation fails

Jump to solution

The only logs are these McAfee_Common_Bootstrapper...the others dont exist on the machine. The deployments are via SCCM, but I try to install the packet locally and the installation freezes at like 10%... 

McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 7 of 21

Re: ENS Installation fails

Jump to solution

Hi @Eduardo_Zeit,

Thank you for your response. Please share the logs here and we shall review the same for you.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T

Re: ENS Installation fails

Jump to solution

This 2 pics are McAfee_Endpoint_BootStrapper and McAfee_Common_BootStrapper from just now...

McAfee_Common_Bootstrapper.JPG

 

McAfee_Endpoint_BootStrapper.JPG

 

McAfee Employee AdithyanT
McAfee Employee
Report Inappropriate Content
Message 9 of 21

Re: ENS Installation fails

Jump to solution

hi @Eduardo_Zeit,

Thank you for your response and uploading the screenshots. Looks like both the screenshots show the same data. Can you please upload the file for me to investigate? Also, I am curious to know if you find any files under "%temp%\McAfeeLogs\". 

Also, most importantly, can you reboot the machine and confirm if Endpoint Security is already installed on the machine and if not try the installation again?

Also please help me with the Operating system version along with it's build number on this one.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T

Re: ENS Installation fails

Jump to solution

At this moment Im using the McAfee tool to remove all the products from one of the machines. Im going to see what happen after that and let you know....then I upload all the logs after the installation retry it

Thanks a lot for the attention til now!

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community