cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
A1468282
Level 7
Report Inappropriate Content
Message 1 of 5

ENS 10.7 remote deployment using Ansible

Hello,

Our team is currently testing deployment of a package with McAfee ENS 10.7 using third party application called ansible.

But the deployment fails everytime. we are using below commandline. Can you please help us if we are missing something?

Invoke-Command -ScriptBlock  {C:\ansible-test\McAfee_Endpoint_Security_10.7.0.824.9_full_package_with_Hotfix\setupEP.exe ADDLOCAL="tp" /quiet /nocontentupdate}

this is via powershell

C:\ansible-test\McAfee_Endpoint_Security_10.7.0.824.9_full_package_with_Hotfix\setupEP.exe ADDLOCAL="tp" /quiet /nocontentupdate

this is via command prompt

Regards,
Akshata Surve

4 Replies
Former Member
Not applicable
Report Inappropriate Content
Message 2 of 5

Re: ENS 10.7 remote deployment using Ansible

Hi @A1468282 

The commands themselves look fine. I have a few questions: Did this work with previous builds? Are any logs generated? Especially in the case via CMD - as long as you are doing this via CMD as Admin it should work unless the actual installation is failing.

Check in C:\Windows\Temp if any logs were generated.

A1468282
Level 7
Report Inappropriate Content
Message 3 of 5

Re: ENS 10.7 remote deployment using Ansible

Yes, attaching logs

Former Member
Not applicable
Report Inappropriate Content
Message 4 of 5

Re: ENS 10.7 remote deployment using Ansible

Hi @A1468282 

The shared logs are not installation created logs. They belong to the EPR Tool - used to uninstall products. This log file is indicating that you need to reboot the machine to complete the removal.

Can you run the installation via CMD as Admin and check again if any installation related logs are created?

Former Member
Not applicable
Report Inappropriate Content
Message 5 of 5

Re: ENS 10.7 remote deployment using Ansible

hi i have a similar problem i am using ansible system for automation of mcafee installations. I have a powershell script that works fine locally, if I launch it remotely via ansible, the installation starts "endpoint install" but after a few seconds it dies ... what could it be? the script is very simple:


$ mcafee = "C: \ Temp \ McAfee \ McAfee_vse \ setupEP.exe"
$ arguments = 'ADDLOCAL = "TP" / quiet'
start-process $ mcafee $ arguments -Wait

this powershell script work in local but from ansible system not work.... from remote this script start (I see the task) but installer after few second dies... 

thanks for any suggestion

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community