cancel
Showing results for 
Search instead for 
Did you mean: 

Agent upgrade issue

Hello all, I'm trying to eventually move to ENS and am starting off by working towards getting agents upgraded.  Out of an abundance of caution, I decided I'd start off by putting my computer in the evaluation group and then upgrade my agent from 4.8 to 5.0.6. 

The upgrade appears to take place in that i can look at my local logs, they look completely different and show versions 5.0.6.220, however, then never "do" anything other than show what the next time of the local task is.  Additionally, if I click on the mcafee product logs tab, it shows no products listed.  Also, if I look in ePO now, it shows my last communication was yesterday when I first tried the deployment.

Any suggestions on this?

Thanks,

6 Replies

Re: Agent upgrade issue

Maybe you to run into the problems that 5.0.6 has.

That is that the agent-sevice stops when you have some tasks running at system-startup or logon.

Can you open your agent-monitor and see if you can send and collect props or check policies?

Then check in the sevices if the masvc.exe "McAfee Agent Service" is running.

Best regards

Dan

Best regards
Dan

Re: Agent upgrade issue

Daniel_S,

I do show that the mcafee Agent service is running, but when I try to send and receive props, it sais Agent failed to collect properties.

Re: Agent upgrade issue

So everything you try is underlined in red?

So could you please remove the agent: frminst.exe /forceuninstall and then do a fresh agentinstall from the ePO.

Maybe during the update, I am not even 100% sure that you can go directly from 4.8 to 5.0.6, something went wrong.

Best regards

Dan

Best regards
Dan

Re: Agent upgrade issue

Daniel,

Eventually after removal and redeployment, it worked, though it made a duplicate system.  That wasn't an issue for a single system, but it certainly has me concerned trying to update 900+ systems. How do I do this correctly and not have this type of problem?

Re: Agent upgrade issue

Now the behavior with the duplicate is normal as the system gets a new GUID and as such is recognized as a new agent.

You still didn´t answer my question regarding the running-tasks: Do you have tasks running at system-startup or login?

Best regards

Dan

Best regards
Dan
Highlighted

Re: Agent upgrade issue

Sorry I never got back to this.  I ended up having a very strange issue that ended up requireing hours on the phone with support.  In the end my issue ended up being believe it or not, a corrupt OU in ePO.  Agent updates worked in other OU's but the one I was using for testing it would always have problems and we ended up deleting it and recreating it to fix the problem.

Member Rewards
McAfee Community rewards active and helpful members just like you. Click here to take a look at the first community members who received a special reward and were recognized by McAfee leader, Aneel Jaeel, for their participation and trusted knowledge in the community.