Showing results for 
Search instead for 
Did you mean: 
Level 9

"Failed to create key" - EEPC 7.0 Offline Installation


I am learning my way through the Endpoint Encryption products in a test lab environment. My setup is as follows:

EPO 4.6.4 Build 202 (on Windows Server 2008 virtual machine)

Endpoint Encryption for PC 7.0.0 311

Endpoint Encryption Agent for Windows 7.0.0 311

Windows XP w/SP3 virtual machine

I was testing out the Offline Activation feature of EEPC, using the following guide:

Following all the steps, I created the installation package, copied the files to my XP virtual machine, and performed all the necessary installation commands. For the UserList.txt configuration file, I simply used Password as the token type.

After running the OfflineActivation.exe file, I checked the log file to see if activation was successful, and saw "key data is invalid failed to create key", along with "errorID 301924350", and "activation aborted":

2013-03-05 15:25:29,754 INFO StatusService Preboot File System (PBFS) creation complete

2013-03-05 15:25:29,770 ERROR MfeEpePcEncryptionProviderPlugin ..\..\..\Src\EpeGenActivationHandler.cpp: EPE_gen_activation_handler::backup_keys_locally: 786: [0xCF060002] Key data is invalid failed to create key

2013-03-05 15:25:29,770 ERROR MfeEpePcEncryptionProviderPlugin ..\..\..\Src\EpeGenActivationHandler.cpp: EPE_gen_activation_handler::backup_keys_locally: 888: Failed to backup keys locally. Activation aborted.

2013-03-05 15:25:29,770 WARNING MfeEpePcEncryptionProviderPlugin ..\..\..\Src\EpeGenActivationHandler.cpp: EPE_gen_activation_handler::send_activate_exception: 926: Failed to backup keys

2013-03-05 15:25:29,770 WARNING MfeEpeCoreEncryptionPlugin receive_from_service_first_message_of_type(MfeEpeEncryptionServiceClient, class ns1__ESActivateEncryptionAck) wrong message received:

<?xml version="1.0" encoding="UTF-8"?><MfeEpeMessageList xmlnsSmiley FrustratedOAP-ENV=""xmlnsSmiley FrustratedOAP-ENC=""xmlns:xsi=""xmlns:xsd=""xmlns:ns1=""xsi:type="ns1:MfeEpeMessageList"><element xsi:type="ns1:ESActivateEncryptionExc">

<sendTo xsi:type="ns1:MfeEpeAddress" serviceUUID="5145540F-1BA8-4F52-895D-617839C2869E" serviceName="MfeEpeEncryptionServiceClient"></sendTo>

<from xsi:type="ns1:MfeEpeAddress" serviceUUID="70e77e64-14e4-467d-8d22-775dc78d7c3b" serviceName="MfeEpeEncryptionService"></from>


<message>Failed to backup keys</message>


2013-03-05 15:25:29,785 INFO PcSystem Abandoning activation

2013-03-05 15:25:29,864 ERROR StatusService Activation abandoned

I haven't been able to find information about how to troubleshoot why this is failing, so anything that can point me in the right direction is much appreciated!

0 Kudos