cancel
Showing results for 
Search instead for 
Did you mean: 
rmmiles
Level 10
Report Inappropriate Content
Message 1 of 4

ePO 4.6 - Web API - eeadmin.changeUserPassword Permissions?

Ok, so the new eeadmin.changeUserPassword command works great if the user executing the command has "global administrator" permissions. I tried running this command with a "non-gobal administrator" account, which had all the "Endpoint Encryption" settings set to "Change and view policy settings" and "Allow", yet receive the following message, "Error 0 : Authorization failed". If I change the permission for the same account to "global administrator" it works just fine. Does anyone know the appropriate permissions to allow the "eeadmin.changeUserPassword" command to be run via the Web API?

Thanks,

3 Replies
whgibbo
Level 12
Report Inappropriate Content
Message 2 of 4

Re: ePO 4.6 - Web API - eeadmin.changeUserPassword Permissions?

Hi,

You will need to have the Endpoint Encryption 'User Management: Change and view user management' permission. 

Please enable this and test that you can add users via the ePO UI, then try the script again.

Hope this helps

rmmiles
Level 10
Report Inappropriate Content
Message 3 of 4

Re: ePO 4.6 - Web API - eeadmin.changeUserPassword Permissions?

Thanks for the responce:

Correction from my first post, I meant to say that I do have "Change and view user management" as well as "Change and view policy settings" enabled for the permission set this user is a member of and still no luck.

I've attached a screenshot of the "Endpoint Encryption" permissions for this permission set.

ee_perms.gif

McAfee Employee kthomas
McAfee Employee
Report Inappropriate Content
Message 4 of 4

Re: ePO 4.6 - Web API - eeadmin.changeUserPassword Permissions?

Knowledgebase team update:

To assist others who find this posting we have created an article to cover this topic.

KB74006 INTERNAL - AuthorizationException: Authorization failed (when using EEPC 6.1 P2 Web API commands)


This is fixed in EEPC 6.2.

Kb.mcafee
http://kb.mcafee.com/agent/index?page=content&id=KB74006

Kev

Kevin Thomas
Knowledge Analyst (Global Online Services)
KnowledgeBase: http://mysupport.mcafee.com


More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community