Showing results for 
Search instead for 
Did you mean: 
Level 7

Windows 7 issue Agent 5.0.4­49


     we recently installed Windows 10 on a few computers (from 15 to 30) and we had to upgrade McAfee Agent to version because of the anniversairy update. This seem to work well but the agent on ours Windows 7 computers are uninstalling ramdomly and a lots of them are unmanaged. When we try to remotly push the agent to the computers, the log show this error: the specified network name is no longer available

We can ping the computer from ePo (version 5.3).

A different version of VSE is installed depending on the OS (8.1->   7-> .777  10-> .1599)

When we install the agent on Win 7, VSE is installing and the agent seem to uninstall right after.

     The same thing happened once on a Win 10 but an agent reinstall solved it quickly.

Some Win 7 agent stay installed for unknow reason.

There is not problem with Windows 8.1 yet.

On this page:McAfee Corporate KB - Problèmes connus de McAfee Agent 5.0.x KB83895 , it say that agent version 5.0.2 or higher with SYScore are not compatible with Windows 7, but this fix :


is no longer supported by Microsoft.

     Is it a  compatibility issue about Windows 7 and this agent version?

     Else, how can we «manage» all our computer with all their OS?

                                                                                                                        Thank you!


The problem is now on 2 other Windows 10. When the agent is installed(english), we click on «Collect and send props». Then the agent stop and restart in french (normal, this is the wanted langage). Then, if we click on «Collect and send props» again, the agent is uninstalling but the VSE is still there and the McAfee tray Icon state to «ok». We can click on «Update security» and it seem to update something but the agent is still not installed and the computer stay unmanaged.


The probleme seem to be solved when removing msiexec.exe from the exclude list in acces protection rule. Now we need to cleen uninstall the agent before installing another one on Windweos 7 (but it's ok for Windows 8.1 and 10) but the agent stay installed. We just need to test a few things.

0 Kudos
5 Replies
Level 7

Re: Windows 7 issue Agent 5.0.4­49

Please, check the next article: KB87328.

You shouldn't have upgraded to McAfee Agent without no upgrading first your endpoint product to the latest version, because that version of MA upgrades the SYSCore, and many issues comes along after installing it.

Without logs I am not able to troubleshoot the strange behavior of MA, but you should take a machine, gather a MER, and open a ticket with support, we will happily help you to further investigate this problem.



0 Kudos
Level 7

Re: Windows 7 issue Agent 5.0.4­49

We upgraded McAfee agent to as soon as the patch was posted (because we had Windows 10 installed).

For the agent logs, they all have normal entries (refering to other posts in the forum). We have Windows logs but it's french version.

The only way I found to keep the agent installed is when the McAfee tray icon menu show all options but the Agent monitor. The "About" section show a unmanaged agent. Then, I run FramePkg.exe and the computer stay in managed mode.

This can be long, depending on the problem (after a clean install, we have 4 differents problem cases) and it depend on luck.

0 Kudos
Level 7

Re: Windows 7 issue Agent 5.0.4­49

MA is a HF released to solve many issues.

As I can see your problem, the SYSCore version is not correctly being upgraded as your endpoint product has a lower version of SYSCore. Take a machine that is unmanaged, and:


Open a cmd as admin, and search for MA path:

"c:\Program Files\Network Associates\Common Framework\frminst.exe" /forceuninstall

"c:\Program Files\McAfee\Common Framework\frminst.exe" /forceuninstall

NOTE: The path will vary depending on the version and whether you installed McAfee Agent as an upgrade or clean installation. Use Windows Explorer to determine the correct path.


Open control, and uninstall VSE


Reboot the system, and then execute run: regedit.exe and delete any entry that starts with *mfe, or named McAfee and Network Associates (make sure to make a backup before making the modification):


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ (check from the top if there is any McAfee remains)








C:\Program Files\Common Files\McAfee

C:\Program Files\McAfee

C:\Program Files (x86)\McAfee

C:\Program Files (x86)\Common Files\McAfee


C:\Windows\System32\drivers\(any entry with mfe)

Now, reboot once again, use the locally the framepkg.exe, and install directly to VSE 8.8p8.

If it that works, repeat it again, but instead locally execute the MA package, do it from the ePO.



0 Kudos
Level 20

Re: Windows 7 issue Agent 5.0.4­49

     Successfully moved from Support Forums to Encryption: ePO Managed > Discussions

McAfee Volunteer
0 Kudos
McAfee Employee

Re: Windows 7 issue Agent 5.0.4­49

Please move this to the ePO group as this issue is not Encryption related.

0 Kudos