Showing results for 
Search instead for 
Did you mean: 
Level 7
Report Inappropriate Content
Message 1 of 3

FRP 4.3 - plenty of issues with Removable Media Offsite Access Encryption

Hi everyone

I must encrypt a few 3 TB external USB disks with technical documentation for archive purpose. I recently upgraded FRP from 4.2 to 4.3 version and trying complete this job using McAfee FRP Removable Media Encryption with Offsite Access. Unfortunately I encounter plenty of problems with this module. Entire disks initialization runs without any trouble. I setup correct authentication and recovery password and   I tried WD and Seagate disks formatted as MBR and GPT partition style. It does not matter on the occurrence of problems. In my opinion everything is properly installed and configured, all ePo 5.1.0 modules are out of date. Issues mentioned above are for example:

- very slow data transfer (below 2MB/s through USB 2.0) between source and target encrypted container (it's minor bug)

- when I try offsite access files from PC without McAfee, credentials prompt appear and after successfully authenticated I must wait very long time period before McAfee Media Browser starts and show files in container

- when I try add for example folder with ISO files (about 15GB) from PC (offsite access) McAfee Media Browser application MfeEERM.exe unexpectedly stop working and crash with 0x0000005 code in event viewer

- sometimes when I add few files to encrypted disk, unmount it and mount again some files even dissapear from disk or have 0 KB size and are corrupted

I tried 4 different workstation (Win7, Win8.1) and 4 external disks (WD, Seagate) for testing purpose but this didn't solve issues. I suppose that is something wrong with McAfee File and Removable Media Protection module. Sadly I can't use FRP for this purpose because I looking for reliable solution. Did anyone experienced similar problems? Can someone help me?


2 Replies
McAfee Employee nav_chakrapani
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: FRP 4.3 - plenty of issues with Removable Media Offsite Access Encryption

One of the main considerations for the offsite mode is enabling users without admin rights to be able to access the encrypted container without having to ever install any software/drivers on the target device. This is because it is not always guaranteed that you will have Admin privileges on all machines that you are try to access the encrypted device. So, all required encryption software is carried with the container; mounting is achieved as a virtual path, and is exposed through our explorer. Hence, data transfers might be slower compared to a copy operation to an unencrypted device.

Item 2: Do you have a lot of files on your device when you try the offsite mode? Is the impact considerable as compared to an encrypted device?

Items 3 & 4: Best to contact McAfee Support, haven't come across these

Level 7
Report Inappropriate Content
Message 3 of 3

Re: FRP 4.3 - plenty of issues with Removable Media Offsite Access Encryption

Thanks for your reply. I don't have lot of files on encrypted device. I guess that problem is in FRP module, which work very slowly, unstable, unexpectedly and overall very not satisfying. When I contacted with Support McAfee claims that I have installed client on not supported Polish version of Windows 7 SP1. Very funny Now I must install English OS and try prove them that are mistaken.

More McAfee Tools to Help You
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • Visit: Business Service Portal
  • More: Search Knowledge Articles
  • ePolicy Orchestrator Support

    • Download the new ePolicy Orchestrator (ePO) Support Center Extension which simplifies ePO management and provides support resources directly in the console. Learn more about ePO Support Center