cancel
Showing results for 
Search instead for 
Did you mean: 
nsacmerc
Level 7

EEPC Offline Installation Failure

Hello Everyone,

I am trying to do an Offline Installation of EEPC with the newest evaluation copy of McAfee EEPC. I am using the instructions found in:

https://kc.mcafee.com/resources/sites/MCAFEE/content/live/PRODUCT_DOCUMENTATION/24000/PD24867/en_US/...

I believe I am doing everything correctly up until the point where I install the OfflineActivation.exe. During that step, I get an "Activation Abandoned" message in the Encryption Drive Status. I also get the following log error in the MfeEpE.log:

2015-07-11 16:29:05,666 WARNING MfeEpePcEncryptionProviderPlugin ..\..\..\Src\EpeGenActivationHandler.cpp: EPE_gen_activation_handler::send_activate_exception: 932: [0xEE050006] Following exceptions were raised when processing user list

class MFE_invalid_parameter_exception: [0xCF000003] malformed utf-16: Code :3472883715

2015-07-11 16:29:05,666 WARNING MfeEpeCoreEncryptionPlugin       receive_from_service_first_message_of_type(MfeEpeEncryptionServiceClient, class ns1__ESActivateEncryptionAck) wrong message received:

<?xml version="1.0" encoding="UTF-8"?><MfeEpeMessageList xmlnsSmiley FrustratedOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"xmlnsSmiley FrustratedOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"xmlns:xsd="http://www.w3.org/2001/XMLSchema"xmlns:ns1=""xsi:type="ns1:MfeEpeMessageList"><element xsi:type="ns1:ESActivateEncryptionExc">

   <sendTo xsi:type="ns1:MfeEpeAddress" serviceUUID="5145540F-1BA8-4F52-895D-617839C2869E" serviceName="MfeEpeEncryptionServiceClient"></sendTo>
   <from xsi:type="ns1:MfeEpeAddress" serviceUUID="70e77e64-14e4-467d-8d22-775dc78d7c3b" serviceName="MfeEpeEncryptionService"></from>
   <errorId>-301662202</errorId>
   <message>[0xEE050006] Following exceptions were raised when processing user list&#xA;class MFE_invalid_parameter_exception: [0xCF000003] malformed utf-16: Code :3472883715</message>

    </element></MfeEpeMessageList>

2015-07-11 16:29:05,666 INFOPcSystem                         Abandoning activation
2015-07-11 16:29:05,666 ERROR   StatusService                    Activation abandoned

I created a UserList.txt and I believe I populated it properly (the file only contains: User: Password). If I change Password to something invalid, the OfflineActivation.exe fails to be generated as expected.

Does anyone know why I might be encountering this error or what I can do to solve it?

Thank you.

0 Kudos
7 Replies
sathish.l
Level 11

Re: EEPC Offline Installation Failure

This is expected behavior, you need to specify the supported Token type in the Userlist.txt.

As per the McAfee Drive Encryption product guide, The following token types are only supported for offline activation:

• Password

• Four Self-Initiating (SI) token types (Gemalto, ActivID, PIV, and CAC)

I'm assuming you are typing the user's password in the Userlist.txt configuration file, in order to set the password, activate the client, reboot the machine, you will have to login with the username specified and enter the default password and will be prompted to change the password at the preboot.

0 Kudos
nsacmerc
Level 7

Re: EEPC Offline Installation Failure

Thank you very much for the reply Sathish.

For clarification, my UserList.txt file contents are included below for a Windows User Name of 'Joe' with a Windows Password of 'windowspass':

Joe: Password

Is that the proper contents for the file? If so, even after a reboot, it does not appear to be working properly. I do not get a pre-boot console. I also get the following error message in the MfeEpe.log after the restart:

2015-07-14 04:59:27,668 ERROR   PluginManager                    Failed to create plugin MfeEpeCoreEncryptionPlugin

I should note the OS is Windows 7 x64 and it is being run in a VMware VM (Hardware version 6).

If you see anything that might be wrong with my configuration or if you can explain the behavior I am seeing, I would greatly appreciate it. Thanks again.

0 Kudos
sathish.l
Level 11

Re: EEPC Offline Installation Failure

I would recommend you start from scratch by following the below link and share the outcomes.

0 Kudos
nsacmerc
Level 7

Re: EEPC Offline Installation Failure

Thank you for your response both Satish and jhall2.

jhall2 + Sathish:

Thank you for clarification on this. The UserList.txt syntax matches what I used during my initial test.

Sathish:

I started from scratch, following the instructions you provided. Unfortunately, I run into the same issue. I still get the following error after attempting to run OfflineActivation.exe (which only runs for around 10 seconds before closing out):

2015-07-14 22:34:51,955 ERROR   StatusService                  Failed to add Drive Encryption users
2015-07-14 22:34:51,955 WARNING MfeEpePcEncryptionProviderPlugin..\..\..\Src\EpeGenActivationHandler.cpp: EPE_gen_activation_handler::send_activate_exception: 932: [0xEE050006] Following exceptions were raised when processing user list

class MFE_invalid_parameter_exception: [0xCF000003] malformed utf-16: Code :3472883715

2015-07-14 22:34:51,955 WARNING MfeEpeCoreEncryptionPlugin     receive_from_service_first_message_of_type(MfeEpeEncryptionServiceClient, class ns1__ESActivateEncryptionAck) wrong message received:

<?xml version="1.0" encoding="UTF-8"?><MfeEpeMessageList xmlnsSmiley FrustratedOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"xmlnsSmiley FrustratedOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"xmlns:xsd="http://www.w3.org/2001/XMLSchema"xmlns:ns1=""xsi:type="ns1:MfeEpeMessageList"><element xsi:type="ns1:ESActivateEncryptionExc">

<sendTo xsi:type="ns1:MfeEpeAddress" serviceUUID="5145540F-1BA8-4F52-895D-617839C2869E" serviceName="MfeEpeEncryptionServiceClient"></sendTo>
<from xsi:type="ns1:MfeEpeAddress" serviceUUID="70e77e64-14e4-467d-8d22-775dc78d7c3b" serviceName="MfeEpeEncryptionService"></from>
<errorId>-301662202</errorId>
<message>[0xEE050006] Following exceptions were raised when processing user list&#xA;class MFE_invalid_parameter_exception: [0xCF000003] malformed utf-16: Code :3472883715</message>

    </element></MfeEpeMessageList>

2015-07-14 22:34:51,970 INFOPcSystem                       Abandoning activation
2015-07-14 22:34:51,970 ERROR   StatusService                 

Activation abandoned

On the subsequent reboot, I do not get the pre-boot console.

The only thing I can think of is I had difficulty finding the EpeOaGenXml.exe file. It did not appear to be provided anywhere in the Encryption_CDA.zip file that is provided by McAfee for the evaluation version of EEPC (manual exploration yielded nothing and a search including contents of zip files turned up nothing). I was forced to find a download site that had it, but I cannot be certain it matches the appropriate version. Perhaps that is resulting in the malformed UTF-16 error.

Would you happen to know if the EpeOaGenXml.exe is anywhere in the Encryption_CDA.zip file? If not, do you know where I can download a version of this file that matches the evaluation version of EEPC (7.1.3 on the ePO server component and 7.1.1 on the client components that are installed by MfeEEPc64.msi)? In lieu of that, can someone upload a version of the file so I can see if that is the cause of the issue?

If I cannot obtain that file in any way, I could alternatively provide my ePO_Policy.xml and UserList.txt files so others could process them with EpeOaGenXml.exe and send the resulting files.

Thank you again for all your assistance.

0 Kudos
nsacmerc
Level 7

Re: EEPC Offline Installation Failure

Hello Again,

I hadn't heard back in quite some time and was hoping to get a little clarity on this. Right now, I seem unable to perform an offline activation using any of the steps I have found for doing so (including the set of instructions you provided Sathish). I suspect it may have to do with the version of my EpeOaGenXml.exe, but I found no instructions anywhere on how to obtain a version that matches the evaluation version of McAfee CDA I am using.

Thank you again for any help you can provide.

0 Kudos
nclark
Level 7

Re: EEPC Offline Installation Failure

nsacmerc,

Was this ever resolved?  I had the same problem and it appeared to be a version issue.  After downloading the latest drive encryption file, I located the EEAdminTools.zip file and in there is the EpeOaGenXml.exe.  After running that against my original policy and userlist it worked fine.

0 Kudos
McAfee Employee

Re: EEPC Offline Installation Failure

Three things about the UserList.txt file:

1. The entry is the username and token type not the username and the password. ie. jhall2Smiley Tongueassword or nsacmercSmiley TongueIV

2. The entry is case sensitive. Utilize teh --help switch on the EpeOaGenXml.exe to get the proper case for the token.

3. There should not be a space between the username and the token ie. nsacmercSmiley Tongueassword

0 Kudos