Showing results for 
Show  only  | Search instead for 
Did you mean: 

EEPC 6.1, Latitude E6420 ATG, Unable to log on Windows


Wondering if anyone's encountered this: Recently we reimaged (wiped and reinstalled a Windows image) a Dell Latitude E6420 ATG. It had Windows 7 before and worked fine, but ever since the reimage once Endpoint Encryption begins (well, a few minutes after it begins) you can't log in to Windows, or if you were logged in when it began you can't unlock the workstation later, and if you were logged in frequently Explorer.exe no longer responds (keyboard [CAPS lock] and mouse still work though). The HDD indicator above the keyboard is solid; even if I leave the computer on over the weekend I come back Monday the HDD's still solid activity and nothing is responsive.

I checked for updates on Dell's website for the E6420 ATG and incorporated the latest drivers into the image. Even tried Intel's latest Chipset (which was just the iaStor file). System's on the latest BIOS too (A08).

The on-board diagnostics (selectable at boot) ran and found no problems.

According to Device Manager in Safe Mode (which works fine) the system is using an Intel 6 Series / C200 Series chipset driver and the AHCI storage controller. The ATG also has a touch screen and a SSD (Lite-On LAT-128M2S 128 GB).

Deploy the same image, but without the Endpoint Encryption agent/client (so encryption never starts) and the system appears fine.

Deploy the same image without Dell's system drivers and now the unlock workstation doesn't completely hang for hours on end, it returns to CTRL + ALT + DEL after about a minute (as if the blank spot where the username/password fields would be are timing out due to inactivity). So, progress in some sense.

  • [Edit] Addendum: As soon as I posted this the prompt for a password appeared, so I typed it and hit enter. Been three minutes now and it's just sitting at the background image with nothing else showing up (HDD LED still solid). If there are any changes I'll pass them on, but performance still sub-par as-is.
  • [Edit 2] Follow-up: Again it timed out to C.A.D., so I tried again and the password box appeared with my password in it. Curious I clicked the 'go' arrow instead of pressing Enter on the keyboard and the system logged in. Explorer is responsive. Got a popup saying VSE wasn't enabled though. The Encryption status window I left open was right where I left it (around 8-10%) in the progress bar. Tried opening VSE to check it and closing/reopening the Encryption status window, but now the system's taking its time. I tried launching task manager to check it and resource monitor, but it's also still pending (HDD is still solid, but I saw it flicker off for half a second once).
  • [Edit 3] After twenty minutes I finally got resource manager up, but it only shows processes for the CPU so I can't confirm what's locked the HDD activity up. Curious, though, is the graphs on the right work; the graph axis is from 0 to 1 KB/sec (a *bit* low I'd say) and the blue line is at the top 99% of the time with the other 1% a very quick dip down to 0 and then immediately back up to 1 KB/sec. By comparison the SSD in my E6520 starts at 1 KB/sec, but then jumps up to 10 MB/sec eventually. If the graph is right it looks like the drive has the throughput of a straw when what I need is a firehose. Now, another 10 minutes later, there are items under disk and a single column of Disk I/O (green) in the graph with a corresponding jump in network activity and CPU use. A minute later another column of Disk I/O (green), but no corresponding jump in network/CPU usage. -- Encryption Status window opened and the progress bar is still around 8% (just under the 'g' in Progress), still says "C: - Encrypting" and System State is "Active." -- We don't have another ATG to test with, but I may try putting a SSD from an E6520 into the E6420 ATG unit when one becomes available just to see if it helps.

To my knowledge this has not happened on any other system, including the standard Latitude E6420 (which is the model we're deploying to employees currently). We only have a handful of ATG units--still, I'd like to fix it instead of tell people we'll have to replace their machine (kind of need the semi-rugged/rugged model for some field workers).

If anyone's seen this issue, or something like it, I'd appreciate any information that may help identify why I can't log into Windows once the ATG is encrypted and why/how its pegging the HDD or causing the system to hang.

Thank you.

Message was edited by: pcktech on 12/13/11 7:38:10 AM CST, 12/13/11 7:55:11 AM CST

Message was edited by: pcktech on 12/13/11 8:37:55 AM CST
3 Replies

Re: EEPC 6.1, Latitude E6420 ATG, Unable to log on Windows

I don't have any definite answers, but I do have a few ideas about additional details that could be helpful.

          Raid is default on these models and the Dell BIOS has had some historical problems with this hard drive mode and EEPC. Switching to AHCI may help.

  • If you are running Vista or Win7, have you looked at the Reliability report for the system for clues?

  • Did you or can you capture the Event Viewer logs on a system that is impacted with the issue?

  • Have you captured the MfeEpe.log and scanned it for error messages?

  • Have you looked at the running Windows services and tried basic process of elimination to see if a non-core service is at fault?

The Dell E6220 and Dell E6420's are among the models we're deploying globally and they have had back to back BIOS issues. I'm not confident that Dell has worked everything out, but having more information may give some clues about how to proceed. I think you can switch between RAID and AHCI without reimaging as long as you have Vista or Win7, but I doubt going to ATA would allow the system to boot. Windows XP isn't very good about accepting drive mode changes and may require a reimage to test the various SATA modes.

I have some other ideas, but it would require a download of the Sysinternals tools from - I don't usually go that route unless I've exhausted the basics, but I have been able to track down the cause of some pretty difficult problems that would have been almost impossible otherwise.


Re: EEPC 6.1, Latitude E6420 ATG, Unable to log on Windows


Thank you zeitgeist for your recommendations, and I'm sorry I couldn't reply sooner (got sick), but I did find a solution Thursday. I had to do a full disk format; not a quick format, but the one or two hour long format. I did it using diskpart > FORMAT FS=NTFS

By default our reimaging scripts use FORMAT FS=NTFS QUICK, but apparently that wasn't erasing enough data from the disk. My only speculation is it has to do with SSDs, Full Drive Encryption, and how SSDs deal with data cleanup. Not sure if this is an issue with the Lite-On SSD in the E6420 ATG or not; I don't think we've deployed many E6520s (Samsung SSDs) in order to compare--could even be a one-time deal.

So, to summarize: If full disk encryption causes your SSD to lock up try a full format of the hard drive. Full formats may not be ideal for SSDs, but it seems to have done the trick in this case.

Level 14
Report Inappropriate Content
Message 4 of 4

Re: EEPC 6.1, Latitude E6420 ATG, Unable to log on Windows

Any solution frm McAfee on it?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community