Showing results for 
Search instead for 
Did you mean: 
Level 13

Can't update 6.2.1 to 7.1.1 via command line

As mentioned in this post here:

I have a number of encrypted machines v6.2.1.315 that i had to manually upgrade from 6.1.1 to 6.2.1 as they wouldn't upgrade via my default ePO task.

I have discovered that i need to manually upgrade these too to 7.1.1 via command line (as I've already tried my task which fails-During my deployment task to install 7.1.1 agent and DE, the DEagent reports into ePO as version 7.1.1 instead of )  and the article above seems to suggest i need to do same.

However, when following the command line options (McAfee KnowledgeBase - How to install/upgrade Drive Encryption 7.1 from the command line ) to upgrade i get an error.

Installation/Upgrade typeDE
Command line

Upgrade from EEPC 6.1.2 (and later) to DE 7.1.0


64-bitmsiexec.exe /i MfeEEAgent64.msi REINSTALL=ALL REINSTALLMODE=vomus

32-bitmsiexec.exe /i MfeEEAgent32.msi REINSTALL=ALL REINSTALLMODE=vomus

DE Client 1

64-bitmsiexec.exe /i MfeEEPc64.msi

32-bitmsiexec.exe /i MfeEEPc32.msi

When i try and install the agent via cmdline, the msi log says it was successful. So i try and install DE but it comes up with an error "An incompatible version of the agent is installed. Please ensure a compatible version of the agent is installed."

When i check the application plugins in registry for EEADMIN_1000 says its still v which shows that it hasn't actually updated, so i run the update again (says successful) and reboot, but it still doesn't update.

my cmdlines are:

msiexec.exe /i MfeEEAgent64.msi REINSTALL=ALL REINSTALLMODE=vomus /norestart /lv c:\windows\temp\mfeeagent64.log

msiexec.exe /i MfeEEPc64.msi /promptrestart /lv c:\windows\temp\mfeeepc64.log

If i try and just run a msiexec.exe /i MfeEEAgent64.msi /norestart /lv c:\windows\temp\mfeeagent64.log for the agent, then it comes up with an error for a registry key which relates to the Epetrayplugin.dll.

Product: McAfee Drive Encryption Agent -- Error 1402. Could not open key: UNKNOWN\Components\BCD65D0725CDE694EB637CC4FD690B1C\AFD293B0BC81E3A40B6BC32853B9688C.  System error 5.  Verify that you have sufficient access to that key, or contact your support personnel.


that registry key has no permissions for anyone at all.

It appears that the command line for updating the agent from 6.2.1 doesn't work. Does anyone have any ideas at all please? I was just about to start the upgrade and these machines were my last test- and now 6.2.1 is no longer supported.



0 Kudos