cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 6

Safeboot.fs found more than once

I am using Safeboot 4.2.7 and has deployed Safeboot to one of the laptops recently. However this laptops doesn't report to the management console and shows up an error '[5b040003] SAFEBOOT.FS block detected more than once'

Fortunately boot protection is not enabled yet and the sberrors.ini file only says the error means safeboot.fs block is detected more than once, which is pretty clear from the error mesaage.

I have managed to run Safetech once on this machine though it is only available through remote access. But Safetech wasn't able to detect the safeboot installation hence not of much use. Also i have uninstalled using sbsetup -uninstall to no avail.

Finally i am thinking of using sbfs to recreate safeboot filesystem. But not sure of how that goes and is not left with any clue on how to resolve this and start encryption.

We have decided to go in for the latest version of MEE but this will take a while. As always we are in need to resolve this before that.

I have googled enough and browsed all the threads on the community before posting this. Any help or input on resolving this is much appreciated.

Laptop make is HP 2210b and i have managed to deploy on many other laptops of similar make without any issues.

Cheers
5 Replies
Former Member
Not applicable
Report Inappropriate Content
Message 2 of 6

RE: Safeboot.fs found more than once

If the machine you are having the trouble with is not encrypted (or you can boot it all the way up), just run a backup and reimage. I wouldn't work to hard on fixing a problem with one machine when the masses are in need of a significant upgrade.

Most of the issues we had with 4.x went away when we upgraded to 5.x. Sure 5.x has a few bugs too, but the support for it is definitely better since it is a more current product.
Former Member
Not applicable
Report Inappropriate Content
Message 3 of 6

RE: Safeboot.fs found more than once

Hi mrgui

Thanks for your reply. As you correctly said I have an option of reimaging as the drive is not encrypted or boot protection is not enabled yet. That is always there for me in the pipeline.

However in most cases these machines will be available only through remote access and without any assistance from support team. It will be only an end user who will be available even for any offline recovery.

Just to avoid this eventuality I am trying to understand the actual issue, given that i have an option to hold this particular machine for some more time.

Later to this post only i have identified that HP's Protection tools consisting of another version of Safeboot are also installed on the machine happy and i have finally managed to unisntall them.

After that we had a hard time booting the machine due to the error 'Sbalg.sys not found', may be due to existence of another version of Safeboot (which was installed by us) Now waiting for the machine to be available again for confirmation. Hope this resolves the issue.

I will post updates.
Former Member
Not applicable
Report Inappropriate Content
Message 4 of 6

RE: Safeboot.fs found more than once

That sounds like the SBALG.SYS file was delete from C:\Windows\system32\drivers folder. I have heard in previous posts, if you can get it into recovery mode, you can copy serial.sys and name it sbalg.sys. This will allow you to properly clean the registry and remove those dependencies. Once that is done, delete the fake sbalg.sys and reboot. You can then attempt to reinstall the software properly.
Former Member
Not applicable
Report Inappropriate Content
Message 5 of 6

Resolved by uninstalling HP's version of Safeboot

Problem is resolved by uninstalling the version of Safeboot that came with HP Protection Tools. Just to avoid spending time upon reboot to resolve the error 'Windows\system32\drivers\sbalg.sys not found' I simply reinstalled the version of Safeboot we use, before rebooting the machine.

This resolved the issue and Safeboot started functioning as expected.

It would have been much easier to figure out if at all HP hasn't kept Safeboot disguised under the name of HP Protection Tools.
SafeBoot
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 6 of 6

RE: Resolved by uninstalling HP's version of Safeboot

but it's not SafeBoot (or McAfee Endpoint Encrypoint for PC's / Device Encryption for PC's) - it's a completley differnet product from HP.

sure, it's an OEM varient of the above, but it's certainly not the same product - there are a lot of pretty important differences, the boot code, management, client etc are all different.
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community