Showing results for 
Search instead for 
Did you mean: 
Level 7

SafeBoot v4.2 & Windows 7

Hi all,

I'm a new IT Manager at my organization and currently we are working with SafeBoot v4.2 Administration and clients.

I was wondering if the 4.2 client can be installed on Win7 laptop ?

If not - can i simply install a newer version or i need to upgrade my management server with the 4.2 DB  ?


0 Kudos
1 Reply
Level 15

Re: SafeBoot v4.2 & Windows 7

According to:

you need EEPC 5.2.x version to support Windows 7.

I suggest to upgrade to latest EEM 5.2.x and EEPC 5.2.x.

0 Kudos