cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7
Report Inappropriate Content
Message 1 of 7

SBADMCL visibility to Deleted Items?

Is there any way to report on the checkin date, etc. of Deleted Machines and Deleted Users without actually restoring them to a machine / user group and then running the report? If not, are there any plans to incorporate Deleted Item reporting into future revisions of MEE?
6 Replies
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 7

RE: SBADMCL visibility to Deleted Items?

sorry no - there's no API and no current plans to write any reports for deleted items for the EEM5 codebase. If you need it you can always talk to your account manager about raising a feature request.
Highlighted
Level 7
Report Inappropriate Content
Message 3 of 7

RE: SBADMCL visibility to Deleted Items?

No worries, thanks very much for your reply. I'll just restore / report / re-delete in the meantime! happy
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 4 of 7

RE: SBADMCL visibility to Deleted Items?

I guess you know there are api commands to restore machines and users - just restore them to a group which is not used for anything else, then you can run your report over them and then delete them again.
Highlighted
Level 7
Report Inappropriate Content
Message 5 of 7

Perma-Deleting from group ate up licenses?

Hey Simon, I was going through and trying to clean up Deleted Machines tonight... I restored to a group I wasn't using, ran GetLastCheckinDate, and then "Permanently Deleted" the machines that hadn't checked in for a year (i.e. highlight machine names in the group, right-click > Delete, tic the "Permanently Delete" box).

All was going well until I noticed that I was not reclaiming the licenses that I was perma-deleting. In fact, machines that I did not move back to Deleted Machines somehow have counted against my license count. I've verified and re-verified and can't figure this out.

I did try a group scan - picked up nothing there either.

I'm running rev 5420 (and can't upgrade just yet) - any ideas or think it's best for me to open a case with Support? Is there a database cleanup / remediation tool that might be available that I've overlooked?
Highlighted
Level 7
Report Inappropriate Content
Message 6 of 7

Never mind :)

I really need to learn to complete all of my troubleshooting before posting here. 😄

So before I gave up for the night, I ran toastcache - that freed up my licenses for me again. I'd be interested to know why this worked whereas cycling the database server service did not work... but am quite happy that it worked!
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 7 of 7

RE: Never mind :)

interesting - it would seem to be a cache issue with the API. (restarting the server does not clear the cache).

what version of the API are you using? It might be something already fixed in later releases.
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community