cancel
Showing results for 
Search instead for 
Did you mean: 

Error db020002: Unable to get attribute data

I'm working with a remote counterpart who is setting up a new installation of EEPC.  He was able to get everything setup and encrypted three machines.  However,  one of the machines won't synch properly.  In the SbClientLog.txt it shows the error above right after it tries to authenticate to the database.

  In the EEM, when I looked up this machines Object ID,  the name shows as "00000002.00000004", and I can open up its properties and everything looks fine. But when I try to do a Forcesynch,  I get the same error.

  I have tried deleting the index, and rebuilding it with the -getcounts command in the SBADMCL Utility, and it throws error "db000004:  The name was not found in the database."

  In digging around,  I noticed that in the SBDATA folder, that the file for 0000004 has a  "0c400047.DAT" file, which none of the other machine objects seem to have.

  I have also tried to set the machine object to "remove" in the EEM, hoping that a synch would go far enough to start decrypting the drive, and we could just remove the software and start over, but no luck.

  Has anyone seen/fixed this issue before?  Can anyone tell me if that extra DAT file means anything?  Is there anyway to determine what attribute everything is looking for and if there is a way to "trick" it into working?

4 Replies

Re: Error db020002: Unable to get attribute data

Which version of EEPC?

That file is one byte size and legitimate attribute.

Please post full SbClientLog.txt. Is hard drive encrypted? Pre-boot present?

If not, reinstall client (SBsetup.exe  -uninstall).

For corrupted database, export that machine object first, then perform offline database maintenance with orphan check and "cleanupmachinegroup" SBADMCL command.

Highlighted

Re: Error db020002: Unable to get attribute data

Running EEPC 5.2.3,  hard drive is encrypted,  Pre-Boot is present, using AutoBoot user to authenticate.

--Stopped EEPC Database Server

--Ran  CleanupMachineGroup Command

     -- Found 1 object in group, (1 valid, 0 removed), Operation Completed Sucessfully

--Ran RenameMachinetoNetworkName command on group that contains machine object

  -- 0xdb020002 Unable to get attribute data

Re: Error db020002: Unable to get attribute data

Maybe you have damaged object attribute set. Restore object from backup, or reinstall client.

Reliable Contributor SafeBoot
Reliable Contributor
Report Inappropriate Content
Message 5 of 5

Re: Error db020002: Unable to get attribute data

sounds like the name attribute is corrupt - have you been using the same account for multiple simultaneous logins maybe?

You'll need to restore the 08400001.dat attribute from a backup, or make a new one up by modifying an existing file with a new (unicode) name.

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community