cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble installing MSME 8.5 on Exchange 2013 ET server

I have an Exchange 2013 SP1 Edge Transport server in my DMZ that I'm trying to install MSME 8.5 onto.

The installer goes through OK (apart from quick flashes of red text when some of the later PowerShell scripts run). When it finishes it says that the installation was successful but when I run Get-TransportAgent there are no McAfee agents listed.

All the McAfee services are running but when I launch MSME Product Configuration I just get a blank page and nothing ever appears.

Please tell me what I'm doing wrong.

Thanks.

Andy.

Update: I get these errors when manually trying to install the agents:

McAfee Security for Microsoft Exchange - Agent install error.PNG

6 Replies
McAfee Employee tlange
McAfee Employee
Report Inappropriate Content
Message 2 of 7

Re: Trouble installing MSME 8.5 on Exchange 2013 ET server

in the e2007 agents folder does it show a file named mcCominteroptx64.dll and if so is there another file by the same name with a .tlb extension (mcCominteroptx64.tlb)?

if the dll is there but no tlb file try the following

open a cmd prompt and cd to the msme\bin folder and type this command as is.

Configurex64.exe RegisterMcCOMInterop

that should create the tlb file.  if so then re-run the install-agent script.

Re: Trouble installing MSME 8.5 on Exchange 2013 ET server


Hi,

Yes, both files are there:

-a---        07/09/2014     15:14      31592 McComInteropX64.dll

-a---        07/10/2014     11:36       3680 McComInteropX64.tlb

Andy.

McAfee Employee tlange
McAfee Employee
Report Inappropriate Content
Message 4 of 7

Re: Trouble installing MSME 8.5 on Exchange 2013 ET server

do you have this microsoft hot fix installed?

http://support.microsoft.com/kb/2938053/en-us

if not that will need to be installed before trying to install the msme agent.

Re: Trouble installing MSME 8.5 on Exchange 2013 ET server

Thanks. I didn't realise that fix applied to MSME 8.5 as well. There's nothing in any NAI KB to indicate that. Just saying...

OK, so I've applied the fix. The installation seemed to go better this time, and now the transport agents are registered, loaded and running. That's much better:

McAfee Security for Microsoft Exchange - Agents running.PNG

However, I still can't launch the Product Configuration Console:

MSME - Cant launch the console.PNG

I feel we're heading in the right direction. Any further ideas, please?

Thanks,

Andy.


McAfee Employee tlange
McAfee Employee
Report Inappropriate Content
Message 6 of 7

Re: Trouble installing MSME 8.5 on Exchange 2013 ET server

you are correct.  we do have a kb with reference to msme 8 and the MS hot fix (KB81356) but it hasn't been updated to include 8.5.  i'll make sure that info is added though.

as for the ui, one possibility is UAC is not allowing the page to be viewed because it isn't running as admin.  you can first try right clicking on the IE icon and choose run as admin to open a new browser.  then copy the link above into the url and see if the page then opens.   

also what happens if you put in https://

even if it doen't launch you should have gotten some type of response instead of a blank page.  you might want to look at the iis logs to see if the request to open the site is even getting sent.  i would also look in iis manager and make sure the msme web site got created.

Highlighted

Re: Trouble installing MSME 8.5 on Exchange 2013 ET server

OK. I've got the web console working now. IIS needed an extra feature installing: StaticFileModule

See the following Microsoft TechNet article for details: Browsing to static content returns a blank page or HTTP 500 Server Error message in Internet Informa...

In brief: To resolve this problem, install the Static Content feature of the Common HTTP Features under the Web Server role on the webserver.

McAfee Security for Microsoft Exchange - IIS Requirement.PNG

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community