cancel
Showing results for 
Search instead for 
Did you mean: 
Hentie
Level 7
Report Inappropriate Content
Message 1 of 5

ConfigClient.cpp,156,Cache Failed

We have a problem where SMTP fails on the server.We uninstalled GroupShield completely and reinstalled it. We had Microsoft looking at it and they advice that it's groupshield causing problems. Still waiting for their reports...

The below cut are the only error we found in GroupShield Debug log, after setting debug to meduim.

transportscan_0.log
16/07/10 21:47:56.968,2308,ProxyBase.cpp,385,80040218 returned by cfg.GetLong( m_subsystemName + L"_Connect_Timeout", m_lConnectTimeout )
16/07/10 21:47:56.968,2308,ProxyBase.cpp,399,Timeout (connect) set to -1
16/07/10 21:47:56.968,2308,ProxyBase.cpp,400,Timeout (read) set to 300000
16/07/10 21:47:56.968,2308,ProxyBase.cpp,401,Timeout (write) set to 300000
16/07/10 21:47:56.968,2308,ProxyBase.cpp,98,Remote ID of Subsystem Scanner is 0x9d3398
16/07/10 21:47:56.968,2308,ProxyBase.cpp,465,Calling 0 on object 0x9d3398
16/07/10 21:47:56.968,2308,ConfigClient.cpp,143,Cache success
16/07/10 21:47:56.968,2308,SMESharedUtils.cpp,29,Comparing 'gateway' with 'on_access'
16/07/10 21:47:56.968,2308,ConfigClient.cpp,156,Cache Failed
16/07/10 21:47:56.968,2308,ProxyBase.cpp,465,Calling 2 on object 0x4541bf0
16/07/10 21:47:56.968,2308,SMESharedUtils.cpp,29,Comparing 'gateway' with 'od_default'
16/07/10 21:47:56.968,2308,ConfigClient.cpp,156,Cache Failed
16/07/10 21:47:56.968,2308,ProxyBase.cpp,465,Calling 2 on object 0x4541bf0
16/07/10 21:47:56.968,2308,SMESharedUtils.cpp,29,Comparing 'gateway' with 'od_findviruses'
16/07/10 21:47:56.968,2308,ConfigClient.cpp,156,Cache Failed
16/07/10 21:47:56.968,2308,ProxyBase.cpp,465,Calling 2 on object 0x4541bf0
16/07/10 21:47:56.968,2308,SMESharedUtils.cpp,29,Comparing 'gateway' with 'od_removeviruses'
16/07/10 21:47:56.968,2308,ConfigClient.cpp,156,Cache Failed
16/07/10 21:47:56.968,2308,ProxyBase.cpp,465,Calling 2 on object 0x4541bf0
16/07/10 21:47:56.968,2308,SMESharedUtils.cpp,29,Comparing 'gateway' with 'od_find_bannedcontent'
16/07/10 21:47:56.968,2308,ConfigClient.cpp,156,Cache Failed
16/07/10 21:47:56.968,2308,ProxyBase.cpp,465,Calling 2 on object 0x4541bf0
16/07/10 21:47:56.968,2308,SMESharedUtils.cpp,29,Comparing 'gateway' with 'od_remove_bannedcontent'
16/07/10 21:47:56.968,2308,ConfigClient.cpp,156,Cache Failed
16/07/10 21:47:56.968,2308,ProxyBase.cpp,465,Calling 2 on object 0x4541bf0
16/07/10 21:47:56.968,2308,SMESharedUtils.cpp,29,Comparing 'gateway' with 'od_fullscan'
16/07/10 21:47:56.968,2308,ConfigClient.cpp,156,Cache Failed
16/07/10 21:47:56.968,2308,ProxyBase.cpp,465,Calling 2 on object 0x4541bf0
16/07/10 21:47:56.968,2308,SMESharedUtils.cpp,29,Comparing 'gateway' with 'gateway'
16/07/10 21:47:56.968,2308,SMESharedUtils.cpp,33,Found Policy set path for the Policy gateway
16/07/10 21:47:56.968,2308,SubsystemFactory.cpp,146,Creating subsystem Scanner with mode 2 on the local machine
16/07/10 21:47:56.968,2308,DynamicLinkLibrary.cpp,55,Loading library P:\Program Files\McAfee\GroupShield for Exchange\bin\ProxyStub.dll
16/07/10 21:47:56.968,2308,ProxyStub.cpp,110,McCreateASubsystem(proxyScanner, ISubsystem**)
16/07/10 21:47:56.968,2308,ProxyBase.cpp,385,80040218 returned by cfg.GetLong( m_subsystemName + L"_Connect_Timeout", m_lConnectTimeout )

Any ideas as to what to do next.

4 Replies
McAfee Employee tlange
McAfee Employee
Report Inappropriate Content
Message 2 of 5

Re: ConfigClient.cpp,156,Cache Failed

what version of exchange?

what information did you send to ms?  can we take a look at that info?

when you say smtp failed, is there an error that is generated?

did the smtp service terminate unexpectedly?

Just an FYI, when collecting debug logs always set the level to high, don't set a maximum file size and let it run till the issue occurs.

then turn it off.  that way all the necessary info is collected.

have you opened a support call with us?  if not can you do that?

Reliable Contributor Aidan
Reliable Contributor
Report Inappropriate Content
Message 3 of 5

Re: ConfigClient.cpp,156,Cache Failed

Don't believe that to be your issue.

This looks like a log from GSE running on Win2003/Exchange 2003. (proxystub.dll)  is this correct?

Is it definitely GSE version 7.01 (7.0.716.103)???

What is Exchange configuration of server - Frontend, Mailbox, Bridgehead? Clustered -, A/P???  

What is P:\  is this a local drive/partition or is this some sort of shared/SAN/mounted drive??

Are there specific errors in Application event log relating to startup/running of Groupshield for Exchange Service??

Hentie
Level 7
Report Inappropriate Content
Message 4 of 5

Re: ConfigClient.cpp,156,Cache Failed

Seems the problem isn't on Microsoft or on McAfee GroupShield.

Exchange engineers tried to load Antigen on the server. Did the same thing.

The server is Windows 2008 running Exchange 2003. Latest service packs and patches.

the server was part of a mailbox cluster. Currently the only server left while migrating to Exchange 2007.

The P drive it the "Programs" drive. It's the drive where GroupShield was installed on.

As for what was sent to MS. That I been trying to find out for a few days from the exchange engineers, including the report from MS.

Talking with the exchange engineers, suspicions is on IIS and ASP. There was a few errors that popup when looking onto the server console.

As for now. The server is left without any Exchange AV and we speeding migration to Exchange 2007.

McAfee Employee tlange
McAfee Employee
Report Inappropriate Content
Message 5 of 5

Re: ConfigClient.cpp,156,Cache Failed

since it is a cluster you don't need to run transport scanning.  to remove the gse transport components you would need to do the following

install groupshield 7.01

open gui and click settings and diagnostics

under on-access settings uncheck enabled for the transport scanning

open cmd prompt and cd to the ...\groupshield for exchange\bin folder

type configure UnRegisterPostCat

type configure UnRegisterProtocolEventSink

  *****Note***** both the configure cmds are case sensitive

restart iis

restart groupshield

after running the above cmds you can verify that the transport sink is removed by typing (from the bin folder)

cscript mcafeetransport.vbs /enum postcat

you won't see anything listed for mcafee transport if the cmds worked.

this will completely remove the transport components so only the vsapi scanning will occur which is what you want

on a clustered exchange server.

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community