cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
marcus69
Level 9

Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

Hi all,

after installing Patch 7.6.404 i can get no more Updates for AV-Engine and -Database.

Last Update shows up the installation Date of Patch 7.6.404, Updatestatus "No change required" ?!? (please see Screenshot attached)

Clicking "Update Now" does not change anything.

Whats going on here ?

We've discovered this behaviour on every Gateway of customers.

Can anyone confirm ?

Best Regards,

   Marcus

1 Solution

Accepted Solutions
marcus69
Level 9

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

Hi Guillermo,

sorry for beeing late

Yes, basically it is like ijahnke wrote:

  • Log on to Backend (Shell) of Your Email Gateway
  • cd to /etc/cma.d
  • Delete all folders (if present) that match MEG____XXXX except the last one, which should be MEG_____7640 ( I'd recommend to move obsoletes to /home/admin for sure )
  • Click "Update now" on the Frontend in the "Component Management" View
  • => Updates should be successfully installed now

You may need to have root access to move/delete the folders. If You do not know how to gain root access rights, please contact McAfee support.

Also You may encounter that Your Update Button or Hyperlink is greyed out, in that case reboot the Email Gateway and after that You should be good to update again.

Best Regards,

    Marcus ;Smiley Happy

11 Replies
ijahnke
Level 11

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

We are seeing an issue on some 7.6.404 appliances where the AV updater isnt working properly and we will be publishing a KB article on it. If you call into support we should be able to fix rather quickly with a remote session.

0 Kudos
marcus69
Level 9

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

Yes, we've already opened a support case on this. The first level support told us that this is a known issue.

We've discovered that it seems to affect Email Gateways that were installed prior to Version 7.6.4.

The only thing to do is to move/delete some obsolete folders in the directory /etc/cma.d on the backend to fix this issue.

But to be honest, we're now almost at Day 20 after Release of 7.6.404, McAfee knows the issue and there is still no KB Article or hotfix available.

McAfee does not cover themseves with glory on this

Best Regards,

    Marcus

willyzen
Level 7

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

marcus69,

Can you confirm if the folders you mention that need to be moved/deleted are:

251319 drwxr-xr-x 2 root root 4.0K Apr 11 20:10 MEG_____7630

250988 drwxr-xr-x 2 root root 4.0K Apr 11 16:43 MEG_____7640

Thanks in advance,

Guillermo

0 Kudos
ijahnke
Level 11

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

Any of the MEG____XXXX folders that are less than MEG_____7640. So MEG____7600, MEG____7610, MEG____7620, and MEG____7630.

0 Kudos
marcus69
Level 9

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

Hi Guillermo,

sorry for beeing late

Yes, basically it is like ijahnke wrote:

  • Log on to Backend (Shell) of Your Email Gateway
  • cd to /etc/cma.d
  • Delete all folders (if present) that match MEG____XXXX except the last one, which should be MEG_____7640 ( I'd recommend to move obsoletes to /home/admin for sure )
  • Click "Update now" on the Frontend in the "Component Management" View
  • => Updates should be successfully installed now

You may need to have root access to move/delete the folders. If You do not know how to gain root access rights, please contact McAfee support.

Also You may encounter that Your Update Button or Hyperlink is greyed out, in that case reboot the Email Gateway and after that You should be good to update again.

Best Regards,

    Marcus ;Smiley Happy

willyzen
Level 7

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

Don't worry for the delay Marcus, the information was very useful. Thanks!

0 Kudos
willyzen
Level 7

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

ijahnke,

Do you have any further information regarding when this KB will be available?

Thanks in advance,

Guillermo

0 Kudos
ijahnke
Level 11

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

We are currently working on a hotfix to resolve the issue. It should be available later this week or beginning of next week.

0 Kudos
cds
Level 7

Re: Email Gateway 7.6.404 does not update AV-Engine and -Database

Jump to solution

Hi

its now a week since the first post here. Is there any KB article in the making? Or some kind of real fix?

We still have customers on .403 where we held back the .404 update because of this problem.

0 Kudos