cancel
Showing results for 
Search instead for 
Did you mean: 
Reliable Contributor haaris
Reliable Contributor
Report Inappropriate Content
Message 1 of 13

HDLP Policy not working in safe mode

I have created a block policy for all file types in DLP endpoint 9.3 patch1& it is working fine but when I tried that by reboting machine in safe mode it is not worwking & files are copying in pen drive instead of blocking.........

Framework service is showing as stopped on client machine & when trying to restart it its not allowing to do that but that is not my concern,problem is that prevous policy applied should work whether services are stopped are not........

12 Replies
epository
Level 10
Report Inappropriate Content
Message 2 of 13

Re: HDLP Policy not working in safe mode

I think this is a documented shortcoming of dlp...its basically dead on in safe mode.....however there is a microsoft hotfix u can install and use a gpo to add a registry key...and it should prevent regular users from booting to into safe mode.

Dlp will record machines being booted into safe mode...u can check the setupapi.dev.log on those machines to see if any sd or usb were used.

Reliable Contributor SafeBoot
Reliable Contributor
Report Inappropriate Content
Message 3 of 13

Re: HDLP Policy not working in safe mode

Re: HDLP Policy not working in safe mode

Did you enable the option to work in Safe Mode? It is under Advanced Configuration of the Agent Configuration.

epository
Level 10
Report Inappropriate Content
Message 5 of 13

Re: HDLP Policy not working in safe mode

This feature is to allow DLP to run and actively block removable storage in Safe Mode, or only to protect itself from being deleted?

Can you elaborate on this feature?

Reliable Contributor SafeBoot
Reliable Contributor
Report Inappropriate Content
Message 6 of 13

Re: HDLP Policy not working in safe mode

epository
Level 10
Report Inappropriate Content
Message 7 of 13

Re: HDLP Policy not working in safe mode

That is good news...so, in short, DLP 9.3 will still work in Safe Mode.....

Reliable Contributor haaris
Reliable Contributor
Report Inappropriate Content
Message 8 of 13

Re: HDLP Policy not working in safe mode

I have enabled the option of safe mode in advanced configuration...& the policy  which are applied before moving to safe mode is working fine,but in safe mode i cant apply any new policy as agent is not running in safe mode & when i try to start the services it it giving me msg that you cant start the service.......

Is it OK or there is something i am missing????

Plz let m know

Re: HDLP Policy not working in safe mode

What is the Agent version? Are you running the policy in Backward Compatibility Mode?

Reliable Contributor haaris
Reliable Contributor
Report Inappropriate Content
Message 10 of 13

Re: HDLP Policy not working in safe mode

The agent version is 4.6.0..........Yes we are running the policy in backward compatibility mode,do we need to change it to no compatibility mode?????