cancel
Showing results for 
Search instead for 
Did you mean: 
leehouren
Level 8

DLP 9.3 Installation Causes Delay / Slow

Jump to solution

We are currently deploying DLP 9.3 for a Customer

After implementing DLP 9.3 agent, all users experience obvious delay intheir workstation. Symptoms as below

  1.        Receiving Emails in Outlook takes about 20 - 30 minutes
  2.        Opening Attachments in Outlook takes a long time
  3.        Opening documents and application, .word, .excel and .pdf have delay
  4.        Opening Files on Network Share have long delays

Customer is currently using Symantec Endpoint ProtectionVersion 12.1.4013.4013 in their environment for Anti-Virus, Device Control and Firewall.

We have tried numerous troubleshooting, below scenario seems to show most improvement

1. Scenario 1

Uninstall DLPEndpoint from system, only running McAfee Agent.

Results: Emailretrieves fast and open files /application within 5 seconds.

2. Scenario 2

Uninstall SymantecEndpoint from system

Results: Emailretrieves within 30 seconds (download 10 emails) and open files / applicationwithin 20 seconds.

3. Scenario 3

Running SymantecEndpoint & DLP Endpoint together, disable Symantec Outlook Plugin.

Results: Downloademail and open attachment files from email within 10 seconds, but open files /applications still take 1 -2 minutes.

We have tried installing DLP 9.2.2, issue still persists.

We have engaged McAfee Support, not much findings on MERlogs.

Do you have any suggestions on this?

Have any similar experiences? Your feedback is greatly appreciated.

Message was edited by: leehouren on 11/26/13 10:37:54 PM CST
0 Kudos
1 Solution

Accepted Solutions
leehouren
Level 8

Re: DLP 9.3 Installation Causes Delay / Slow

Jump to solution

My issue was solved by doing the following:

1.All done at the Symantec Manager for the users workstations

  • Disabled Symantec Internet Email Auto-Protect.Receiving Email instantly becomes faster

  • Disabled Symantec Outlook plugin.

2.Have applied KB71116 - Slow performance on systems running Host DLP9.x when opening or copying a file from Windows 2008 server share to Windows 7

   The hotfix seemed to fix the delays almost immediately, still monitoringon this.



0 Kudos
8 Replies
keithdrone
Level 10

Re: DLP 9.3 Installation Causes Delay / Slow

Jump to solution

#1

Check your exclusions in your Symantec.   See https://kc.mcafee.com/corporate/index?page=content&id=KB68520  for more details.

#2 

Check your DLP trusted applications list.  You should exclude the symantec processes from all scanning by making them 'Trusted'.

#3

Check what rules you have enabled.  The more rule you utilize, the slower things will be.   Also, combining Application Tagging rules with On-Access can rules will slow things down tremendously.

#4

If you did not perform some QA testing, and/or lack the understanding of the product you are deploying, you likley should not be in this business or role.  

0 Kudos
leehouren
Level 8

Re: DLP 9.3 Installation Causes Delay / Slow

Jump to solution

Hi Keithdrone,

Appreciate the response,

#1

Check your exclusions in your Symantec.   See https://kc.mcafee.com/corporate/index?page=content&id=KB68520  for more details.

We have included exclusions both in DLP and Symantec. Still slow

#2

Check your DLP trusted applications list.  You should exclude the symantec processes from all scanning by making them 'Trusted'.

Done that. Still Slow

#3

Check what rules you have enabled.  The more rule you utilize, the slower things will be.   Also, combining Application Tagging rules with On-Access can rules will slow things down tremendously.

We have not applied any rules yet.

#4 For the opening files Network Share slow, have applied KB71116, https://kc.mcafee.com/corporate/index?page=content&id=KB71116&cat=TROUBLESHOOTING&actp=LIST the Microsoft HotFix seem to have fix it. but we are still monitoring on Production and awaiting feedback from users.

0 Kudos
bphang
Level 10

Re: DLP 9.3 Installation Causes Delay / Slow

Jump to solution

Judging from that, looks like both added the overhead that slows down the system.

You might want to check your DLPe policy. Adding a security tools always cause some kind of delay [but not to 30 mins ]

For network share file opening slowness, you might want to try using 9.3 p1.

There are some file lock issues fixed from both Symantec and MFE DLPe end.

0 Kudos
Secure-It22
Level 9

Re: DLP 9.3 Installation Causes Delay / Slow

Jump to solution

You need to  re-build your  Symantec Antivirus packages without the “Outlook Auto Protect”Feature. And redeploy it to all machines, this would fix your outlook attachments/outlook performance issues. To fix your file copy issues, turn-off "file transfer protection" . Hope this helps.

0 Kudos
omendoza
Level 7

Re: DLP 9.3 Installation Causes Delay / Slow

Jump to solution

My environment:

Windows 7

McAfee Agent 4.8

McAfee VirusScan 8.8

McAfee DLP 9.3.100 and 9.3.200

McAfee Endpoint Encryption 7.0.2

Windows Server 2008 R2 for our file server

I pushed out DLP 9.3.100 to our end users and they all experienced slowness accessing our shared drives.  I updated to DLP 9.3.200 and still experienced the slowness.  I uninstalled DLP from their machines and it resolved the slowness. I applied the hotfix mentioned here

https://kc.mcafee.com/corporate/index?page=content&id=KB71116&cat=TROUBLESHOOTING&actp=LIST

and our end users were still experiencing the slowness.  Has anyone found a solution to the latency all around?

0 Kudos
leehouren
Level 8

Re: DLP 9.3 Installation Causes Delay / Slow

Jump to solution

I had this issue, when i applied KB71116, it almost immediately solved.

0 Kudos
michaelm1983
Level 7

Re: DLP 9.3 Installation Causes Delay / Slow

Jump to solution

Hi Omar,

I saw a post that you wrote about slowness on your network. did you get the problem resolved?

really need to get this problem resolved.

many thanks,

Michael

0 Kudos
leehouren
Level 8

Re: DLP 9.3 Installation Causes Delay / Slow

Jump to solution

My issue was solved by doing the following:

1.All done at the Symantec Manager for the users workstations

  • Disabled Symantec Internet Email Auto-Protect.Receiving Email instantly becomes faster

  • Disabled Symantec Outlook plugin.

2.Have applied KB71116 - Slow performance on systems running Host DLP9.x when opening or copying a file from Windows 2008 server share to Windows 7

   The hotfix seemed to fix the delays almost immediately, still monitoringon this.



0 Kudos