cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 6

DLP 9.3 Deployment failure

Hi,

I am trying to deploy the DLP 9.3 module using ePO 4.6. The machine being to deployed to is windows server 2008 standard. I have succesfully deployed HIP and ABM to this server. When I try and deploy DLP, the installation fails. If I copy the installation file from the ePO server to the target machine and manually execute it, the product installs fine and works as it should.

This is error from the Application event log:

Product: McAfee DLP Endpoint -- Error 1904. Module C:\Program Files\McAfee\DLP\Agent\fcemailanalyzer.dll failed to register.  HRESULT -2147024770.  Contact your support personnel.

I have attached the InstallLog from the machine as well.

Regards,

Scott

Message was edited by: bassman134 on 6/24/14 1:44:38 PM CDT
5 Replies
Former Member
Not applicable
Report Inappropriate Content
Message 2 of 6

Re: DLP 9.3 Deployment failure

Please contact McAfee Support.

kmc
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 3 of 6

Re: DLP 9.3 Deployment failure

Hope this is what exactly looking for, I guess it will be helpful for you

McAfee Corporate KB - Installation errors when upgrading manually from Data Loss Prevention Endpoint...

Try and let me know how you go with it!

jhall2
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: DLP 9.3 Deployment failure

The error seen in the MSI log is this:

MSI (s) (F0:E0) [17:50:58:446]: Executing op: RegSelfReg(File=fcemailanalyzer.dll,FileID=fcemailanalyzer.dll_1)

MSI (s) (F0:E0) [17:50:58:555]: Product: McAfee DLP Endpoint -- Error 1904. Module C:\Program Files\McAfee\DLP\Agent\fcemailanalyzer.dll failed to register.  HRESULT -2147024770.  Contact your support personnel.

Error 1904. Module C:\Program Files\McAfee\DLP\Agent\fcemailanalyzer.dll failed to register.  HRESULT -2147024770.  Contact your support personnel.

As kotresha MC states, this appears to be a result of the Microsoft Visual C++ 2010 SP1 Redistributable Package failing to install or not properly being installed.

Re: DLP 9.3 Deployment failure

Hello,

 

I am having the same problem trying to install DLP 11.6.0.762. 

You mentionned that Microsoft Visual C++ 2010 SP1 Redistributable Package is needed to be installed but which version exactly is needed please?

Thanks per advance

Re: DLP 9.3 Deployment failure

To give you an update, I've tried installing Microsoft Visual C++ 2010 SP1 Redistributable Package x86 and x64, it didn't work. Neither the 2013 version.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community