cancel
Showing results for 
Search instead for 
Did you mean: 
danieln
Level 7
Report Inappropriate Content
Message 111 of 132

Re: Mcafee Service Host Error Windows XP

@jeepland

I guess that it's not a Win XP update problem. I have 2 machines, both with Win XP Professional. One I use daily and keep it updated. When my McAfee Antivirus Plus updated last year, the problem started.

I tried the McAfee Virtual Technician once I supposed that the update failed for some reason. It found and fixed 2 problems, but not this one.

I ran it again and it didn't find any error, but his errors were still happening.

So a few days later I turned on my 2nd computer and run the McAfee update (ignoring all Windows and other programs update). After reboot, the problem started on this 2nd machine. I ran MVT and no errors were found.

At this year, I formatted the 1st machine and installed all (not copy) in a new HDD. The WinXP worked fine (SP3 with all updates), with Firefox and IE. After I installed McAfee, it updated by itself sometimes and with the 3rd or 4th update, the problem started again.

After all programs installed, I ran a Defrag (original, from Win XP) and nothing changed.

@Peacekeeper.

Did you asked me about my McAfee copy? It's an original version. My licences are valid until this end of year.

On more thing. With NetGuard enabled, I got 3 errors, with it disabled, I got only 1. Enabling or disabling it several times didn't change anything...

I really can't undertand why mcAfee doesn't fix it.

Thanks.

Highlighted
ergojm
Level 7
Report Inappropriate Content
Message 112 of 132

Re: Mcafee Service Host Error Windows XP

I don't always get "Service host has encountered..." error message but for the last two weeks I have been losing my internet connection from IE at least two to four times a day and I have to either restart windows OR toggle "off" then "on" Mcafee firewall to be able to reconnect. By process of elimination, I have determined that it's the Mcafee firewall causing the loss of internet connection and it's been a major annoyance for my family to go through the effort multiple times a day of toggling the firewall. I tried turning off Netguard last night as suggested in this discussion community and haven't yet gotten a call from my wife complaining about Mcafee...yet so, this is a good sign!

Are others also having this IE connection issue when the service host quits? I wouldn't mind just an error notification if it didn't take out my browser sessions as well, every day.

---------------------------------------------

Update: Since turning off the Netguard, I haven't had an error or had to restart my IE browser for two days - looks like this temp fix works!!

Message was edited by: ergojm on 5/24/12 7:40:19 AM CDT
ergojm
Level 7
Report Inappropriate Content
Message 113 of 132

Re: Mcafee Service Host Error Windows XP

Update: Since turning off Netguard, I haven't had an error or had to restart my IE browser for two days now - Looks like this temp fix works!!

Re: Mcafee Service Host Error Windows XP

Well, my McAfee worries are now over.  I had 61 days left on my subscription, but I just couldn't take it anymore.  Downloaded Bitdefender earlier this afternoon.  High reviews, considerably less expensive, and - BONUS! - my computer no longer sounds like it's trying to achieve escape velocity several times per session.

Good luck to those who stick with this program that's been problematic for six months!

Re: Mcafee Service Host Error Windows XP

I have a xp system which I only use for internet purposes. A few months ago I started receiving "service host error" . which was just a nuisance at the time but

progressed to the point of shutting down my browsers. I thought i had to reboot, which i did for a couple weeks. then i discovered that if i opened the security center and turned off my firewall and waited a few seconds until the red screen came up with the your computer is not protected. I then turned on the firewall and my browser worked. It works for me. Hope it can help someone else.

Re: Mcafee Service Host Error Windows XP

Hello coach477, thank you posting the firewall tip!

I will be trying out it today. If it doesn't work for me, I sure hope it proves helpful for some of the other people having these issues. I'll post my results. Hopefully, others will post their results, too.

Have a great day and take good care of you,

Erin

Re: Mcafee Service Host Error Windows XP

This is an update regarding coach477's tip to turn McAfee's Firewall 'OFF' and then 'ON'...

coach477 wrote:

I have a xp system which I only use for internet purposes. A few months ago I started receiving "service host error" . which was just a nuisance at the time but

progressed to the point of shutting down my browsers. I thought i had to reboot, which i did for a couple weeks. then i discovered that if i opened the security center and turned off my firewall and waited a few seconds until the red screen came up with the your computer is not protected. I then turned on the firewall and my browser worked. It works for me. Hope it can help someone else.


I did find this a helpful 'workaround' when my internet browser stopped my internet connection while on a web site I happened to be visiting. When my browser indicated it couldn't connect to the internet, I tried coach477's tip, and had a working browser connection again! This is still a pain in the rear, but it is simpler than constantly re-booting the system. I didn't find this worked with the 'service host error' message on my computer,  at least, not yet.

PLEASE NOTE: I suggest using caution if deciding to turn your firewall off and on, in the manner I've described above. I've only used this method when I've been reasonably confident I'm on a safe web site.

My operating system is Windows XP Professional with Service Pack 3.

The browser I'm using is Internet Explorer 8.

Anti-virus software program is, obviously, McAfee Internet Security. I have turned 'OFF' the NetGuard in the McAfee program. Which has been suggested by the McAfee techs.

Hope this is helpful for someone. And, thanks for the tip coach477!

Erin

Reliable Contributor Peacekeeper
Reliable Contributor
Report Inappropriate Content
Message 118 of 132

Re: Mcafee Service Host Error Windows XP

OK this thread did not get the update info. The mcsvhost error has a fix waiting to be released first to Au and Ko servers then 1 week later Uk and Us. Mcafee knows the cause and it was not easy but has been fixed so they say. The release of the patch starts very soon.

Message was edited by: Peacekeeper on 28/05/12 1:21:00 PM

Re: Mcafee Service Host Error Windows XP

Well they have a fix !  A little bit late for me as the pop up was coming every 2 to 3 minutes last week. So I called teck support and they took over my computer. After they returned the computer to me it was much worse each time I would close the pop up it would cut me of the Internet .I was on line with Mcafee tech support and they took over my system at least 5 times.

Nothing Worked ! I have written of my payment with McAfee for 2013, Shame really as I used McAfee for many years so I felt they deserved some time to fix the problem. But this past week was to much.

I now have a competitors Internet Security installed and my system is running perfect.

Message was edited by: moop1519 on 5/27/12 8:51:50 PM CDT

Message was edited by: moop1519 on 5/27/12 9:20:40 PM CDT
Reliable Contributor Peacekeeper
Reliable Contributor
Report Inappropriate Content
Message 120 of 132

Re: Mcafee Service Host Error Windows XP

Actually disabling netguard is the accepted workaround a 1 minute fix. This seems to fix teh issue till the patch is released. Netguard is a firewall feature.