Showing results for 
Search instead for 
Did you mean: 
Level 7

McAfee Installation Issue

My Dell Dimension computer recently became infected with the “Google Redirect” virus (while using McAfee by the way).  I ultimately decided to reformat the hard drive and reinstall Windows (XP Media Edition) to get rid of the virus (I was due for a fresh start to improve performance anyway).  Since I’ve gone through the process of reinstalling Windows on this computer a couple of times before I thought I knew what to expect.  Before I reinstalled Windows, I ran the Dell hardware diagnostics utility and everything passed.  I got Windows reinstalled and updated.  Then I installed McAfee from the disk supplied with my computer in 2005.  As I was checking for McAfee updates, I found that they had a new version available for download.  I downloaded this version and installed it thinking that it would automatically replace the older version I had just installed.  However, when I rebooted I still got the McAfee Privacy login pop-up that was part of the old version.  I checked Add/Remove Programs and saw that the components of the old version were still there.  I removed these, but then the new version didn’t work either.  So I decided to remove the new version and try reinstalling it.  When I tried to reinstall the new version, the installer ran for a couple of minutes and then displayed a message saying the installation was incomplete and none of the components could be installed.  I worked with McAfee tech support (level 1 and 2) on three occasions to try to fix this.  They followed what appeared to be a standard troubleshooting flow chart of running a McAfee removal application, trying the installation again, running some Microsoft security permissions patch, re-run the removal application, and try the  installation again.  Finally they would run Windows check disk from the command prompt, which reports “Windows found problems with the file system.”  They then claim that this is why McAfee won’t install and I should contact Dell to fix the problem.  I have researched the check disk utility online and I have run it on three other computers which all reported the same error.  Based on what I’ve read and the fact that check disk seems to always return this error when run in this fashion (I think because it can’t lock the C: drive), I am skeptical that this is in fact the root cause.  Also, I have had no problems with Windows or with installing and running drivers and other applications.  Does anyone know if this check disk error is in fact why McAfee won’t install and, if it is, what I should do to correct the file system problems?

0 Kudos
2 Replies
Level 12

Re: McAfee Installation Issue

Hi Brian,

We really understand your frustration and sorry for the inconvenience caused. Perhaps this may be occurring due to HDD errors also. However, I would recommend you to try the following:

1. Since you had installed the older version of McAfee programs from the disk earlier, please Click on this link to look for the legacy removal tools. Run them as specified and reboot the computer

2. Check for Windows Update, make sure you install all the available Priority and required Optional updates like MSXML, Microsoft.Net Framework etc...


You can also run the removal tool for the latest version (MCPR) again and re-try the installation in Safe Mode with Networking

0 Kudos
Level 7

Re: McAfee Installation Issue

Thanks for the advice.  I finally resolved the problem.  Based on your advice and advice from a Dell forum, I did the following:

1. Ran chkdsk c: /f (scheduled task on reboot) multiple times.  The first time made ~3800 corrections, the second made 10 and the last few reported the same 3 or 4 corrections.

2. Booted from the XP install disk, entered recovery mode and ran chkdsk c: /r.  It reported some files were repaired.

3. Ran two versions of MCPR.exe, and

4. Ran chkdsk from the cmd window.  It still reported file system problems.

5. Logged into Windows under safe mode with networking as Administrator

6. Ran chkdsk from the cmd window.  No problems were reported with the file system.

7. Downloaded and installed the latest version of McAfee.

8. Success!!

9. Rebooted normally and verified McAfee is working.

I didn't follow a scientific method of trying one thing and checking to see if it worked, so I don't know which of the things I did actually resolved the issue.  However, hopefully this info will help someone else with similar issues.

BTW - running chkdsk from the cmd window when logged in normally still reports file system problems.  I think the McAfee tech support needs additional training.