Showing results for 
Search instead for 
Did you mean: 

Javascript Error while attempting to install McAfee

I have read through most of the posts here regarding the problem, i.e., when attempting to install McAfee, the installation cannot continue because Javascript needs to be installed.

I have done the below items -- a few times now:

1.  Click Start and select Run.

    In the Run box, type CMD and click OK.

    In the command prompt, type REGSVR32 JSCRIPT.DLL and         press ENTER.

    After the confirmation message is displayed, type REGSVR32           VBSCRIPT.DLL and press ENTER.

    Close the command prompt


2. Run the McAfee removal tool MCPR.exe & restarted the computer.

    Run the Mcpreinstall tool from here :  McPreInstall.exe and tried reinstalling the products.

Note:  Also tried running the Virtual Technician, but, since I assume it's depending on some javascript?? it only opens the window and nothing appears in the window.

So, I am at a complete loss.  I'm running Vista 64bit.

Please help!

4 Replies

Re: Javascript Error while attempting to install McAfee

Maybe the way to go is explained here

Seems the running as admin helps

Re: Javascript Error while attempting to install McAfee

Thanks. I neglected to say I have run them as admin.

After too many fruitless hours, I did a system restore. Since there are still a couple of wrinkles to work out, I will post results later.

Level 12
Report Inappropriate Content
Message 4 of 5

Re: Javascript Error while attempting to install McAfee

Hi marzo19,

This issue occurs when there is some issue with internet explorer. What I’m suggesting you that, if you have internet explorer 9 installed on your computer, remove it, restart the computer and re-install internet explorer 9. If you’ve internet explorer 8, upgrade it to internet explorer 9 and restart the computer and try to install McAfee.

Re: Javascript Error while attempting to install McAfee

Thanks for the tips above.

Here's a summary of what happened and resolution.

In attempting to repair above (initial problem), a new problem arose due to the an interrupted (re-)install of McAfee.  When McAfee removed a malware program and had to restart to resume installation, connection to internet was blocked. After many futile attempts to troubleshoot the problem, the only solutio was to revert to a restore point prior to all the McAfee issues. From that point, I was able to uninstall fully and re-install with success. I would not have had to re-install at all if I had stopped Iolo System Mechanic from compressing the registry -- this causes McAfee to stop functioning.

A weird and confusing chain of events now resolved.