cancel
Showing results for 
Search instead for 
Did you mean: 
darren13
Level 7

Cannot Connect Windows 7 Desktop to Vista Laptop over Network

Hello guys -

I hope someone here can help, I've been trying to sort this out for hours....!  I've spent a lot of time looking at lots of forums to try to resolve this, but it seems I've done everything I can.  Hopefully it's something simple...

Essentially, I can't connect my Windows 7 Desktop to my Windows Vista Laptop.

Windows 7 is 64 bit Ultimate on the desktop.  Windows Vista Home Basic is on the laptop.

The desktop is connected to the router via an ethernet cable, the laptop is connected via wireless.

Both machines connect very well to the internet with no problems.

I can connect from the laptop to the desktop via the network fine.  Whenever I try to connect to the laptop from the desktop I get:

--------------------------------
Network Error

Windows cannot access \\DARRENLAPTOP

Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems, click Diagnose.

Error code: 0x80070035
The network path was not found.

---------------------------------

I get the exact same error and code when Mcafee Firewall is turned off on the laptop.

I've added both machines' individual IP's in Mcafee Security Centre as 'Trusted'.  I've set up shared folders on both machines, and both are on the 'WORKGROUP'.  I have users on both machines with passwords that match.

I can ping both machines from each other with their IP, and also with their Computer Name.

Both machines show up on each other's Managed Network within Mcafee Security Centre.

I can 'see' the laptop in the Network in Windows Explorer from the desktop, but the above error results whenever I click on it's icon to connect....

I've also done an ipconfig/dnsflush on both machines, and checked that all required network services are running in Services.msc

I found something on techsupportforum.com that recommended providing the following information:

This is for the Desktop

-----------------------------

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\DarrenWin7_2>ping 206.190.60.37

Pinging 206.190.60.37 with 32 bytes of data:
Reply from 206.190.60.37: bytes=32 time=104ms TTL=54
Reply from 206.190.60.37: bytes=32 time=107ms TTL=54
Reply from 206.190.60.37: bytes=32 time=106ms TTL=54
Reply from 206.190.60.37: bytes=32 time=104ms TTL=54

Ping statistics for 206.190.60.37:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 104ms, Maximum = 107ms, Average = 105ms

C:\Users\DarrenWin7_2>ping yahoo.com

Pinging yahoo.com [209.191.122.70] with 32 bytes of data:
Reply from 209.191.122.70: bytes=32 time=185ms TTL=54
Reply from 209.191.122.70: bytes=32 time=185ms TTL=54
Reply from 209.191.122.70: bytes=32 time=184ms TTL=54
Reply from 209.191.122.70: bytes=32 time=186ms TTL=54

Ping statistics for 209.191.122.70:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 184ms, Maximum = 186ms, Average = 185ms

C:\Users\DarrenWin7_2>nbtstat -n

Local Area Connection:
Node IpAddress: [192.168.1.64] Scope Id: []

                NetBIOS Local Name Table

       Name               Type         Status
    ---------------------------------------------
    DARRENWIN7     <00>  UNIQUE      Registered
    WORKGROUP      <00>  GROUP       Registered
    DARRENWIN7     <20>  UNIQUE      Registered
    WORKGROUP      <1E>  GROUP       Registered

Bluetooth Network Connection 4:
Node IpAddress: [0.0.0.0] Scope Id: []

    No names in cache

C:\Users\DarrenWin7_2>ipconfig/all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : DarrenWin7
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : lan

Ethernet adapter Bluetooth Network Connection 4:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
#4
   Physical Address. . . . . . . . . : 11-11-11-11-11-11
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Intel(R) 82562V-2 10/100 Network Connecti
on
   Physical Address. . . . . . . . . : 00-1D-09-82-ED-BF
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::28cd:4854:95fa:c8f5%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.64(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 31 March 2010 15:09:57
   Lease Expires . . . . . . . . . . : 01 April 2010 15:09:57
   Default Gateway . . . . . . . . . : 192.168.1.254
   DHCP Server . . . . . . . . . . . : 192.168.1.254
   DHCPv6 IAID . . . . . . . . . . . : 234888457
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-D8-15-D6-00-1D-09-82-ED-BF

   DNS Servers . . . . . . . . . . . : 192.168.1.254
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{96618AEA-32BA-448D-877C-831F47091E7E}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.lan:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:73ba:38f4:28d0:3f57:febf(Pref
erred)
   Link-local IPv6 Address . . . . . : fe80::38f4:28d0:3f57:febf%22(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Users\DarrenWin7_2>

---------------------------------------------------

And this is for the laptop:

----------------------------------------------

Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft  Corporation.  All rights reserved.

C:\Users\User>ping  206.190.60.37

Pinging 206.190.60.37 with 32 bytes of data:
Reply  from 206.190.60.37:  bytes=32 time=112ms TTL=54
Reply from 206.190.60.37:  bytes=32 time=110ms TTL=54
Reply from 206.190.60.37: bytes=32 time=105ms TTL=54
Reply  from 206.190.60.37:  bytes=32 time=106ms TTL=54

Ping statistics for 206.190.60.37:
     Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate  round trip times in milli-seconds:
    Minimum = 105ms, Maximum =  112ms, Average = 108ms

C:\Users\User>ping yahoo.com

Pinging  yahoo.com [209.191.122.70] with 32 bytes of data:
Reply from 209.191.122.70:  bytes=32 time=176ms TTL=54
Reply from 209.191.122.70:  bytes=32 time=232ms TTL=54
Reply from 209.191.122.70:  bytes=32 time=176ms TTL=54
Reply from 209.191.122.70: bytes=32 time=173ms TTL=54

Ping statistics for 209.191.122.70:
     Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate  round trip times in milli-seconds:
    Minimum = 173ms, Maximum =  232ms, Average = 189ms

C:\Users\User>nbtstat -n

Bluetooth Network Connection:
Node  IpAddress: [0.0.0.0] Scope Id: []

    No names in cache

Local  Area Connection:
Node IpAddress: [0.0.0.0] Scope Id: []

     No names in cache

Wireless Network Connection:
Node IpAddress: [192.168.1.65] Scope  Id: []

                NetBIOS Local Name Table

        Name               Type         Status
     ------------------------------

---------------
     DARRENLAPTOP   <00>  UNIQUE      Registered
     WORKGROUP      <00>  GROUP       Registered
    WORKGROUP       <1E>  GROUP       Registered

C:\Users\User>ipconfig/all

Windows  IP Configuration

   Host Name . . . . . . . . . . . . : DarrenLaptop
   Primary  Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . :  Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy  Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : lan

Ethernet adapter  Bluetooth Network Connection:

   Media State . . . . . . . . . . .  : Media disconnected
   Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : Bluetooth Device (Personal Area  Network)
    Physical Address. . . . . . . . . : 00-1F-3A-DE-01-A6
   DHCP  Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . .  . : Yes

Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix  . : lan
    Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG  Network Con
nection
   Physical Address. . . . . . . . . :  00-1F-3C-20-CD-12
   DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IPv4 Address. . . . . . . . . . . : 192.168.1.65(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. .  . . . . . . . . : Wed 31 March 2010 15:09:54
   Lease Expires . . . .  . . . . . . : Thu 01 April 2010 15:09:54
    Default Gateway . . . . . . . . . : 192.168.1.254
   DHCP Server .  . . . . . . . . . . : 192.168.1.254
   DNS Servers . . . . . . . . .  . . : 192.168.1.254
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . .  . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :  lan
   Description . . . . . . . . . . . : Intel(R) 82566MM Gigabit  Network Connecti
on
   Physical Address. . . . . . . . . : 00-1C-25-7C-90-95
    DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled .  . . . : Yes

C:\Users\User>

------------------------------------------------------------------------
Remote Desktop Connection works absolutely great from the laptop to the PC, but again, I seem to have a network problem going from the PC to the laptop.

Sorry if it's information overload, but I thought I'd include as much information as possible - if you need anything else, please just shout ;-)

Any help at all will be repaid with a thousand thank-you's!

Regards,
Darren
0 Kudos
3 Replies
darren13
Level 7

Re: Cannot Connect Windows 7 Desktop to Vista Laptop over Network

(I've also been in and followed these instructions fromttcshelbyville.wordpress.com/2009/12/17/enable-netbios-over-tcpip)

To enable NetBIOS over TCP/IP on Windows 7:

  1. Click Start, and then click Network.  (click Start, type ncpa.cpl into the search box for  Windows 7 or Vista, hit ENTER).
  2. Click on the Network and Sharing Center
  3. Click Manage Network Connections.
  4. Right click on the Local Area Connection select Properties.
  5. Select Internet Protocol version 4 (TCP/IPv4)
  6. Click the Advanced button under the General tab.
  7. Click the WINS tab.
  8. Click Enable NetBIOS Over TCP/IP.
  9. Click OK and Exit the settings.

Exact same 0x80070035 error when trying to connect to laptop...

Darren.

0 Kudos
darren13
Level 7

Re: Cannot Connect Windows 7 Desktop to Vista Laptop over Network

Okay - bingo -

over at social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/8a052445-514a-44e7-a7bc-9e8dad6c696a

they suggested:

----------------------------------------

  On the Windows 7  and Windows Vista computers, please go to “Control Panel\All Control  Panel Items\Network and Sharing Center\Advanced sharing settings” and  ensure that the following items are turned on:

Network Discovery

File and printer sharing

And this one is OFF:

Password protected sharing

------------------------------------------------------------

Somehow, although 'Printer Sharing' was showing as 'On' in the Network and Sharing Centre, it wasn't.

(on the laptop) - When I went into Network and Sharing > Manage Network Connections> Right Click Wireless Network >  Networking Tab......Printer sharing was not checked!?

That took hours (probably days altogether actually - I've not had this working ever, and I've had the laptop for about 2 years !), but I hope this thread helps someone with a similar problemo!

0 Kudos
darren13
Level 7

Re: Cannot Connect Windows 7 Desktop to Vista Laptop over Network

Not ultimately a Mcafee issue (although I maybe cleared up anthing that might have been on the way through various forums).

My issue was that, although Network and sharing said File and Printer Sharing were turned on, they weren't. Had to enable it specifically on the Wireless network used by my laptop.

Duff information from the Sharing Centre in Vista....

0 Kudos