Showing results for 
Show  only  | Search instead for 
Did you mean: 

App lock not working on Google Pay app

I have reinstalled yhe Google Pay App. When I open it the lock screen appears for a second, then the app opens without me entering the PIN. This does not happen wiyh any other app I have locked.

Can someone suggest a fix please.


2 Replies

Re: App lock not working on Google Pay app

Hi @Johndowning 

We are sorry for the inconvenience.

Kindly try to remove Google Pay from the list of locked apps in McAfee. Re add it to the locked apps and check if the issue occurs again. If the issue persists, open Google Pay>Settings>Privacy & Security and set a pattern, fingerprint or PIN. Let us know the McAfee version and Google Pay version to proceed further.

Karthikeyan J 

Re: App lock not working on Google Pay app

tried all you suggest have reinstalled both Google app and McAfee software, still not working. I have no idea where version numbers might be.

Are you able to assist further please


How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community